Intel i350t4 firmware flash issue



  • Re: [SOLVED]: Intel i350-T4 can't be recognised

    I have tried this step on my windows 10 machine in order to try and flash the firmware to my i350t4 card. When I get to the part where I would run BOOTUTILW64.EXE, it has a message " unable to locate the driver component. Please reinstall program. I figure it must be something that I am missing that is causing this, but I run through the instructions that Corvey placed, and it does not seem to want to work. Any help would be appreciated, as I am trying to see if a firmware update will help it work in my Pfsense box which is an Optiplex 790.



  • I flash/update these cards in Windows 10 too.
    Make sure you have the full latest Intel ProSet drivers installed (not the default M$ ones).
    In device manager, select the network card, select boot rom firmware version -
    then get the latest boot.flb from the Intel download center, select it and flash it...



  • I was able to update it through freeDOS, but it still did not work with my Optiplex 790. My previous intel dual port Pro1000 NIC works perfectly on the same PC. Could there be a way to make it work, or will it just never work due to compatibility?


  • Netgate Administrator

    How does it fail when you try to use it?

    Does the card work in the Optiplex if you boot some other OS?

    Steve


Log in to reply