PfSense 1.2 RC4 connected to a Cisco 2431 IAD



  • I have encountered some issues with connecting my WAN interface on the firewall to a Cisco 2431 IAD.  The WAN interface will arp and pass traffic, but the 1:1 maps are not arping, so the Cisco is not passing traffic to them.

    The Cisco interface is configured rather simply:
    interface FastEthernet0/0
    ip address X.X.X.145 255.255.255.248
    load-interval 30
    duplex auto
    speed auto
    no cdp enable
    service-policy input MARK-PORT-PREC-DATA-IN-POLICY

    I have the WAN IP set to X.X.X.146, a 255.255.255.248 subnet mask, and the gateway set to X.X.X.145.

    I have 1:1 maps on X.X.X.147 and X.X.X.148.  The VIPs for these IPs are set as proxy-arp.

    One item of note.  I tried setting the WAN IP on the pfSense firewall to X.X.X.147 and I can get out, and the 1:1 map seems to continue to work.

    Does anyone have any suggestions or reasons why the 1:1 would not be arping to the router?



  • Just as an update, I was able to get this running normally on 1.2.2 code.



  • As a general rule, you always want to be running the most current release of software before reporting a bug.  1.2 was released more than 2 years ago and 1.2.2 has been out for a long time.  In fact, 1.2.3-RC1 is out now and literally thousands of bugs have been fixed in those 2 years.  I'm glad your problem was solved with a simple upgrade.


Log in to reply