APCUPSD Shutting down PFSense immediatly after boot up



  • I have a Netgate 3100 that I decided to install and configure the APCUPSD package on as a master to control other network devices in the event of a power loss.

    I have an older APC BackUPS XS 1000 which I replaced the battery packs in about 4 years ago.

    My system recognizes the APC UPS, when viewing from the console. Shortly after the APC Daemon runs, PF sense sends a console message that the APCUPSD is shutting down my device.

    It is not giving me any time to get in and modify the configuration.

    I tried booting in single user mode from the console thinking I could either edit the APCUPS config, or remove the entire package install. I could do neither. (lack of permissions) even as su root.

    I have a backup of the system. I am thinking about purchasing a new UPS to see if this is being caused by low battery states. If this doesn't work, can anyone suggest a work-around? I was thinking pressing the reset button to bring back to factory then loading backup as a last resort.

    Appreciate any guidance.

    AJM



  • Also, I have tried to start the device without the cable attached to the UPS. It shutdown all the same, which I think is very odd.



  • Well I have resolved this problem by reinstalling PfSense and applying a backup I made a few days ago.

    Will do more research into APCUPSD before I consider having that control my device again.


Log in to reply