Static IP over PPPoe questions



  • I am having a bear of a time getting a new PFSENSE box to connect to an existing PPPoE connection. It does have a static IP. Using the methods in this link : https://forum.netgate.com/topic/42981/static-ip-on-pppoe-wan-connection I configured the firewall and am still having an issue with it not bringing up the connection. The current service providers router shows the static public WAN IP but the default gateway as 1.2.3.4 (yes really, that's what it shows). When plugged in and rebooted on the ISP's router all is good. Unplug and plug into the pfsense box and it will not bring the interface up and pass traffic. I am at a loss for ideas, as all my other installs have gone without a hitch. Any help would be awesome. My config file is below. I don't see any issues with the file, but then again I am just trying to copy someone elses handywork! ;)

    startup:
    # configure the console
    set console close
    # configure the web server
    set web close

    default:
    pppoeclient:
    create bundle static wan
    set bundle enable ipv6cp
    set iface name pppoe0
    set iface addrs !ASSIGNED_STATIC_IP !1.2.3.4
    set iface disable on-demand
    set iface idle 0
    set iface enable tcpmssfix
    set iface up-script /usr/local/sbin/ppp-linkup
    set iface down-script /usr/local/sbin/ppp-linkdown
    set ipcp ranges 0.0.0.0/0 0.0.0.0/0
    #log -bund -ccp -chat -iface -ipcp -lcp -link

    create link static wan_link0 pppoe
    set link action bundle wan
    set link disable multilink
    set link keep-alive 10 60
    set link max-redial 0
    set link disable chap pap
    set link accept chap pap eap
    set link disable incoming
    set link mtu 1492
    set auth authname "VERIFIED_USERNAME"
    set auth password VERIFIED_PASSWORD
    set pppoe service ""
    set pppoe iface igb5
    open

  • Netgate Administrator

    Ah, yes this can be painful and it's very ISP dependent.
    Since PPPoE is a point to point protocol it doesn't actually need a gateway at all, they probably use 1.2.3.4 just because they had to fill a box somewhere. But pfSense doesn't expect that it needs a route and 1.2.3.4 is not valid.

    You might try omitting !1.2.3.4 so that it still pulls that value from the ISP.

    You might try using the actual next hop the ISP uses.

    Does it connect and not pass traffic or fail to connect entirely? Can we see the ppp log?

    Steve



  • As you suggested @stephenw10, omitting the !1.2.3.4 from the file seemed to be part of the solution. With just removing it from the config and rebooting, I was unable to get the interface to come up. I checked the logfiles again and it showed everything I would expect it to show until it got to the ipv6 dhcp entries. So I went into the PPPoE settings and set ipv6 to None instead of DHCP and rebooted the box. After doing this, the interface came up and showed the correct static IP on the overview page. Checked the interface and it's showing it's gateway as 1.2.3.4 and things are working fantastic... I have about a 12% increase in the fast.com speed tests compared to the comtrend router the ISP provided, so I'd call that a win for sure!!

    Thanks again for the suggestion!!


  • Netgate Administrator

    Nice! Thanks for documenting that. I'm sure it will help someone else at some point. ☺

    Steve


Log in to reply