IPv6 setup with Fido Home Internet

  • Hi everyone,

    I just switched back to Fido Home Internet here in Toronto and while I know they didn't have IPv6 support back in 2017, I'm wondering if they have now pushed it out? My WAN interface appears to be getting an IPv6 address but the same setup I had with Rogers does not appear to work for delegating prefixes to my LAN.

    Can anyone confirm if they have it working or not? If they don't, I'll have to go back to setting up an HE tunnel like the good old days.

  • @lobotiger

    What sort of IPv6 address are you getting? Global or just link local? Also, Fido has a community forum. Perhaps you'd be better off asking there. That link mentions new firmware for IPv6 support.

  • I'm getting link local plus global in this range: 2607:9880.

    I've posted on their forum as well but I'm starting to think that they may still not support it which is a little disappointing.

  • How are the WAN and LAN interfaces configured?

  • On the WAN interface

    IPv6 configuration type = DHCP6
    Use IPv4 connectivity as parent interface is checked
    Use IPv4 connectivity as parent interface is set to 56
    Send IPv6 prefix hint is checked
    Do not allow PD/Address release is checked

    On the LAN interface

    IPv6 configuration type = Track Interface
    on the Track IPv6 Interface, IPv6 Interface is set to my WAN
    IPv6 prefix ID = 0

  • Anyone have any ideas?

  • So I have an update. I needed to reset my pfsense firewall because it was refusing to update to the latest patch (3) on 2.4.4 since earlier this year. After resetting and going through the new install process, I noticed that both my WAN and LAN interfaces had IPv6 addresses assigned. The LAN's was a /64 though.

    I looked into it more to try and reproduce it and it seems that Fido may be setup to offer you only a /64 prefix via PD. I tried setting things in the WAN interface to request a /56, like how Rogers works, but it would not assign any prefixes when setup that way.

    So, right now I'm on Fido's IPv6 network and all that is required to do is the following:

    IPv6 configuration type = DHCP6
    DHCPv6 Prefix Delegation size = 64


    IPv6 configuration type = Track Interface
    on the Track IPv6 Interface, IPv6 Interface is set to my WAN
    IPv6 prefix ID = 0

    The only disappointing thing with this setup is that it won't let you assign other /64s to the rest of your internal VLANs if you have things separated for Guest, IoT, etc.

  • @lobotiger

    Have you called Fido to ask about the prefix size?

  • No not yet as I doubt I'd get anyone on the phone who would even know what IPv6 is. Plus my online account is having problems so I can't post on their forums either at the moment.

Log in to reply