So installed Squid and turned it on…and.....



  • i have the Rc1 build of pfsense 1.2. just released, i used the package installer to install squid and squidguard.

    i enabled quid to watch my LAN connection set the default settings, log location and such.

    and now i get this when ever i try to open my pfsense page, other webpages seem to work fine, but i can not connect to my pfsense…

    ՍԽԱԼ
    Պահանջվող URL չի կարող առաքվել

    Հարցման մշակման ընթացքում:

    GET / HTTP/1.1
    Host: 10.0.1.1
    User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9 (.NET CLR 3.5.30729)
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,/;q=0.8
    Accept-Language: en-us,en;q=0.5
    Accept-Encoding: gzip,deflate
    Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
    Keep-Alive: 300
    Connection: keep-alive

    Տեղի ունեցավ հետևյալ սխալը:

    * Սխալ հարցում

    HTTP հարցման որոշ ասպեկտներ սխալ են. Հնարավոր պատճառներն են:

    * Հարցման մեթոդը բացակայում է կամ անհայտ է
        * URL -ն բացակայում է
        * HTTP իդենտիֆիկատորը բացակայում է (HTTP/1.0)
        * Հարցման ծավալը շատ մեծ է
        * POST կամ PUT հարցումների համար Content-Length չի նշված
        * Անթույլատրելի նիշ սերվերի անվան մեջ;ընդգծման նիշն անթույլատրելի է

    Ձեր քեշի կառավարիչը **@.com է.
    Generated Fri, 24 Apr 2009 20:31:50 GMT by ..com (squid/2.6.STABLE21)

    For one, what language is that,i would assume an English pfsense install would install English packages?

    2nd , how do i get access back to my pfsense? i try to connect and get the above page….

    can i SSH in and reload a backup configuration? If so, any good guides on how to SSH in.. this is fairly new for me.



  • Check language setting in squid GUI and Save



  • i cant access the GUI at all, when i try to access the pfsense interface, i see that page.


  • Rebel Alliance Developer Netgate

    @Mathiau:

    i cant access the GUI at all, when i try to access the pfsense interface, i see that page.

    You may need to uninstall squid from a shell prompt:

    squid -k shutdown
    pkg_delete squid-\*
    

    Then back out to the console menu and use option 11 to restart lighty.

    Move your WebGUI to another port, or just don't set squid to listen on 80. Leave it at 3128 and when you check transparent it will redirect connections as needed, and 80 can still be used by your WebGUI. It doesn't redirect connections going directly to the pfSense box, so the situation you describe should only happen if you also set squid to actually listen on port 80.

    I thought I had fixed the squid package to test for that last Sunday (April 19th), but there may be some cases I missed.



  • great info there! i didnt even think about switching the port to something other then port 80.

    i had set squid to listen on port 80 as i figured it was required for the traffic going through it, figured it was something i did wrong.

    i just reset to factory and restored the backup i did just before i installed squid :) things are running smooth again, and will try to play with squid again today if i have some time.


Log in to reply