Won't boot after install (Beep … ... ... Beep ... ... ... )



  • At the "PF Sense F1" menu, whether I hit F1 or let it time out to boot, it just starts a sequence of about a 1 second beep every 10 seconds or so.

    Q1:  This is PF Sense SW beeping, right?  What does this sequence mean?

    This is an old machine, ~1996 that I have been using with Smoothwall.  The disk is a 1.2GB WD.  Actual geometry is 2484 / 16/ 63.  I set the BIOS to "USER" and "LBA" to avoid the 1024 cyl problem and it comes up with 1027 cyl, 255 heads, 63 sectors (8447MB!).  The capacity of the disk would be 155/255/63.

    Whereever I go from here, it seems to try to make a partition that is too big.  If I manually force a smaller partition (that fits), then it gets to the F1 boot prompt and beeps.

    At this point I would just like to ask how I should handle the situation and go from there.

    Can anyone help?

    Thank you.



  • From everything I have read, it should "Just Work" as long as the disk is dedicated to FreeBSD.  Since I accepted all of the defaults, I assume that this is what was set up.

    I have run lots of tests.  Can someone who understands this tell me what information I might post, or what I might try, or tell me "Clearly this will never work because xyz" ?

    Thanks.

    I have tried the following permutations of BIOS settings and Geometry:

    AUTO (Disk Config) and LBA
    USER (Disk Config) and LBA with 3148 16 63 (I changed to a 1.6G disk)
    USER (Disk Config) and LBA with 787 64 63
    AUTO (Disk Config) and NORMAL

    With AUTO, 3148 16 63 was offered and accepted in the PFSense "Select Geometry" dialog in both cases.

    I always put the same geometry in the BIOS and the PFSense "Select Geometry" dialog.

    For each of these four permutations, I tried the default Boot Boot configuration (No Packet, no Grub), with "Packet", and with "Grub"

    In all cases the Default Boot configuration and the Packet install fine then fail on boot as described previously with the one second Beep every 10 seconds.

    In all cases the Grub configuration failed installation, saying "Cannot mount selected partition".


Log in to reply