Enable LAN interface from Shell



  • I have made a cardinal sin and not looked before de-tabbing the interface for LAN adapter. I therefore cannot log into the pfsense webgui. I have several redundant adapters having changed this around and was cleaning up things (a little too wel in this case).

    Does anyone have an idea how to re-enable the adapter from the shell?. Help would be appreciated thanks. First time this has ever happened to me.


    I have tried command below with no success.

    ifconfig bge0 up

    /etc/rc.linkup opt1 start

    /etc/rc.linkup interface=bge0 action=start


  • Rebel Alliance


  • Netgate Administrator

    You mean you unassigned LAN? You only have a WAN interface?

    If you only have WAN you will be able to login to the gui using that IP, the anti-lockout rule will have been moved to that.

    From the console you can re-assign an interface as LAN from the menu. Or you can also roll-back the config change you last made from that menu.

    Steve



  • @stephenw10 yep. Spot on I just hadn't replied yet. Reassigned the IP on the bge0 interface and it automatically enabled the interface again. Many thanks for the help from all on this thread.

    I did work it out myself but knowing others would have got it as well makes a difference. Thanks.


Log in to reply