Why my Virtual IP setting cannot be saved?



  • Hi,
    We want our externally hosted web server (202.150.yyy.163) to talk to one of our internal web API server. Our pfSense appliance sits behind a Cisco 1800 router and we have 14 WAP IP available behind Cisco router. I use 1:1 NAT to map one of our WAN IP 202.xx.78.133 to internal server 192.168.xx.16. Then I add Virtual IP 202.xx.78.133 as proxy ARP. Our requirement is to make the web server exchange data with our WAN IP 202.xx.78.133.

    This is the exact same steps we used earlier on another externally hosted web server. Our WAN IP 202.xx.78.132 1:1 NAT to our internal server 192.168.xx.12 has no problem talking to the external web server.

    Somehow when we repeat the same steps for the second Virtual IP 202.xx.78.133 (Proxy ARP), the second Virtual IP (202.xx.78.133) just disappears and cannot be saved to the compact flash firmware.

    Could anyone help to share the possible causes of this problem? Is it a compact flash retention problem or something (rules) are missing? Will a reboot help to fix this problem?

    Your advice is greatly appreciated.

    Thanks & Regards,







  • Hi,
    I am using version 1.0.1 customized by appliance supplier. My issue is when I add a new line at Virtual IP, the new setting cannot be saved and it will corrupt my original setting. This appliance has been used since 2007 and we did not have such problem earlier with VIP setting. Hope this info help to narrow my issue.

    Thanks & Regards,



  • 1.0.1 is waaaaaaaaaaaaaaaaaaaaay out of date.
    Update to 1.2.2 or 1.2.3



  • Hi GruensFroeschli,
    We are in the process of seeking pfSense commercial support to move out of our our customized version. We believe pfSense support can help us upgrade to newer stable version. But along the way we have to fix our immediate problem first.

    Is it correct sequence to add virtual IP first, 1:1 NAT second and then firewall rules? Maybe our edit sequence is wrong and this causes a VIP corruption. Still no clue at the moment.

    Regards,



  • What is "customized version" please?



  • Hi,
    We have solved the issue by engaging a network engineer to review our firewall configuration. We do not actually require virtual IP. Just the 1:1 NAT will work. Thanks anyway!


Log in to reply