Problem in squid 2.6



  • i have installed squid package and run it with transparent mode and evry thing is ok
    but after 1 day he has block the web browsing and he redirect me to the web server and ask for user name and pass
    when i cancelled it or run it on non transparent mode the web browsing is ok
    how can i fix it



  • Did you add ports 80/8080/443/53 in your Rules LAN ? Try save and restart your pfsense see if that works.
    jigp
    Davao City



  • Set your webGUI to run on HTTPS port 443.



  • It happens when your squid die's within transparent mode. If this thing happen again. open your shell and run squid -Nd1 then youll see whats the problem. :>



  • OT: Is there a way to change the proxy:port into private proxy_ip:port ? Been exploring the squid+squidguard packages but no luck.. Anyone knows how to configure and set private_proxy_ip:port? Currently im using a local proxy:port default of pfsense squid..
    jigp
    Davao City



  • @jigpe:

    OT: Is there a way to change the proxy:port into private proxy_ip:port ? Been exploring the squid+squidguard packages but no luck.. Anyone knows how to configure and set private_proxy_ip:port? Currently im using a local proxy:port default of pfsense squid..
    jigp
    Davao City

    Via squid > Custom options



  • Hi.Thanks for the quick reply..My Proxy server: General settings >Suppress Squid Versio (checked) > Custom Options : Squid redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf;redirector_bypass on;redirect_children 10… Where to put my private_proxy:port sir? Kindly you me the way.. Ive tried locating in command line using /var/squid/acl but nothing there..even in the cache and log directory... Thanks
    jigp
    Davao City


Locked