Dashboard : unable to add widgets (only system info shows up)



  • pfsense version 1.2.3 RC1 (release).
    The dashboard version is 0.7.5.3
    I am not able to add any widgets to the display.
    Tried in 3 different browsers :
    In Opera just fails silently.
    In IE 6.0 and Firefox gives an error message (d is undefined).


  • Rebel Alliance Developer Netgate

    It works fine for me on 1.2.3-RC1.

    Have you tried to reinstall the Dashboard package? It's possible some files are out of sync.



  • hey jimp.
    I reinstalled the package and it is I was able to add cpu graph for a second.
    Then after I removed , again I can't add anything to the widgets except System Info.
    I am also unable to move the System Info widget around by dragging.
    I tried both in latest Opera and in Firefox (Firefox under Fedora Core 8 and Opera under Windows).


  • Rebel Alliance Developer Netgate

    I'm wondering if it's getting stuck in a weird state again, where it isn't properly replacing the index.php file for whatever reason.

    Sometimes I have had to delete the /usr/local/www/index.php file and reinstall the package again. I haven't yet figured out why, since the code in the package installer should be doing this automatically when (re)installing.

    If you want to try this, I would suggest having two browser windows open, one on the 'installed packages' screen ready to install, and another looking at the main page.

    You can delete it from a shell prompt, or from Diagnostics > Command.



  • Ok forget about it :)
    Turns out my microdrive was bad.
    It crapped on me right after I tried reinstalling the project again.
    Now the box won't boot anymore.
    I will be waiting for a new microdrive which I should receive in a few days.


Log in to reply