RCC-VE-2440 No Serial Output



  • $ sudo /usr/bin/screen /dev/cu.SLAB_USBtoUART 115200
    

    Blank screen with no error messages, and no response to any input. Same result if I pass screen -U, and also same result with cu -s 115200 /dev/cu.SLAB_USBtoUART.

    $ sw_vers
    ProductName:	Mac OS X
    ProductVersion:	10.14.6
    BuildVersion:	18G95
    $ uname -rsv
    Darwin 18.7.0 Darwin Kernel Version 18.7.0: Tue Aug 20 16:57:14 PDT 2019; root:xnu-4903.271.2~2/RELEASE_X86_64
    $ ls /dev | grep cu.SLAB
    cu.SLAB_USBtoUART
    $ kextstat | grep silab
    171    0 0xffffff7f83c1b000 0x9000     0x9000     com.silabs.driver.CP210xVCPDriver (5.2.4) 79BD054F-7A71-34DE-9763-59D44DAC0615 <89 23 5 3>
    $ /usr/bin/screen --version
    Screen version 4.00.03 (FAU) 23-Oct-06
    $ env
    TERM=xterm-256color
    TERM_PROGRAM=Apple_Terminal
    TERM_PROGRAM_VERSION=421.2
    # ... snip ...
    $ sudo kextutil -v /Library/Extensions/SiLabsUSBDriver.kext/
    Defaulting to kernel file '/System/Library/Kernels/kernel'
    /Library/Extensions/SiLabsUSBDriver.kext appears to be loadable (not including linkage for on-disk libraries).
    Loading /Library/Extensions/SiLabsUSBDriver.kext.
    /Library/Extensions/SiLabsUSBDriver.kext successfully loaded (or already loaded).
    $ ioreg -p IOUSB
    +-o Root  <class IORegistryEntry, id 0x100000100, retain 15>
      +-o AppleUSBXHCI Root Hub Simulation@14000000  <class AppleUSBRootHubDevice, id 0x1000003db, registered, matched, active, busy 0 (0 ms), retain 13>
        +-o Apple T1 Controller@14100000  <class AppleUSBDevice, id 0x1000003dd, registered, matched, active, busy 0 (1 ms), retain 34>
        +-o CP2104 USB to UART Bridge Controller@14600000  <class AppleUSBDevice, id 0x10000091a, registered, matched, active, busy 0 (8 ms), retain 14>
    

    Any ideas on where to go from here?


  • Netgate Administrator

    You should see some output from Coreboot when you first power it up on the serial console even if you have no OS installed.
    Open a ticket with us if you are unable to connect to it: https://go.netgate.com

    Steve


Log in to reply