Slow Webpage Loads



  • I've been having trouble with webpages loading very slowly over the past week. It occurs with both wired and wireless connection. It's feels like a DNS problem, but I haven't been any to fix it yet. I'm current running 2.4.4-RELEASE-p3 on a r210ii on a E3-1230 with 16gb ram. The packages I have running are Avahi, bandwidthd, and pfBlockerNG-devel.

    Certain websites load instantly, others can take up to 30 seconds to fully load, it almost always happens with carters.com and cars.usnews.com. I have the DNS resolver setup with forwarding and tried changing from cloudfare to google dns, but no luck. I checked if pfblockerng was causing the issue, but after disabling I didn't see any improvement.

    Any suggestions? Thanks for the help.



  • @kbbeer said in Slow Webpage Loads:

    with forwarding and tried changing from cloudfare to google dns, but no luck.

    What about trying the default pfSense situation for DNS - which is not forwarding ?

    Also : when you feel something, look at it - the tools to do so are included :

    dig cars.usnews.com +trace +short
    

    Looking at these two sites (and peeking at the 'source html') and you know that they are loaded with dozens of external references.
    So, when you open a page at "cars.usnews.com" you are actually opening pages on dozens of others web servers. Most are pure "pfBlockerNG-devel" food : it will block these URL .... and the browser will wait ..... because the DNS resolving will time out.

    Btw : Forwarding to some other - non local - DNS and using pfBlockerNG-devel seems really strange to me.

    Example :

    06639f30-5ce4-4e87-bccd-c5d94179f491-image.png

    Who tells me or you, then when you start to hammer hard external DNS servers, they will not somewhat streamline these requests ?
    If I worked for Google or Cloudware, I would do that to keep up with the fluidity for everbody (doing that, and collecting your search data .... of course).

    And all that knowing that you have you're own full speed DNS 'just for your' with cache, DNSSEC (if needed), etc.


  • Netgate Administrator

    Do you have any IPv6 connectivity? Some partial v6 connection can cause massive issues as things have to timeout v6 if it's broken before falling back to v4.


Log in to reply