Help me with squid guard



  • hey guys.. do have a tutorial for squid guard??? i'm using squid guard 1.3-2..
    i've already tried to follow this tutorial
    http://files.pfsense.org/tutorials/squidguard/squidGuardQuick.htm
    but it doesn't work..
    i've already block the porn but it seems that i can access all porn site..
    do have any other solution beside the squidguard.. to prevent user access to website??



  • Did you look in the packages forum where SquidGuard and indeed blocking porn have recently been discussed?



  • nope..  :P
    can u help me configure squid guard?
    example i want to block the GOOGLE url..
    can i add in to squidguard???



  • Yes, you can.

    If you want to know how, can I suggest you try reading the existing threads.  If you're having trouble finding them there's a wonderful feature called the search button, or look here.



  • i searched already.. and i found ppl seems telling like tutorial said.. and i've already follow it thou but it's failed.  :'(
    i already setup the squidguard configuration
    but i've no idea about the squid because there is no tutorial using squidguard in pfsense..

    plz look at my configuration..
    i know u can help me cry havok  ;D








  • Funny, I used the search function and I found seven pages of posts about SquidGuard.  More than one contained relevant information, like this.

    If that doesn't help you need to actually describe the problem, phrases like "it's failed" or "it doesn't work" provide no information.



  • i searched but not found it  ???
    okay juz to make it clear..
    from the picture above u can see that i've set rules to deny porn,gambling,drugs,proxy,etc..

    example:
    1. i type www.youporn.com <–- it contain "porn" in the URL so the squidguard must blocked it..
    but i can access it..

    2. i type www.proxy4free.com <--- it contain "proxy" in the URL but still not blocked..

    and so does the gambling,drugs,etc

    maybe i'm wrong setting the squid..
    since i'm following the video tutorial on squidguard and i'm sure 100% that the configuration is right..

    or maybe the problem is..
    i don't know the function of squid..
    i read the document it is written that squid for cache..
    is there any correlation between squid and squidguard???
    why must install squid before installing squidguard..

    do we need configuration on squid to activate squidguard?



  • Can I suggest that you actually read about SquidGuard (they have their own web site).  It doesn't work the way you think it does.

    Squid: Proxy server
    SquidGuard: Add-in for Squid to control what sites people can access.

    By installing the SquidGuard package it's automatically enabled in Squid.



  • i've already read those article but it's not helping me..
    still it not blocked the URL.. i'm getting confuse now..
    i'm not configuring squid..
    i only configuring in squid guard.. is it correct?



  • SquidGuard uses lists of domain or host names to block.  Selecting the "porn" list does not block sites with the word "porn" in it's name but sites in the list called "porn".

    Since you obviously failed to find it, try this document on the very basics of how SquidGuard works.



  • thx that's helpfull.. anyway i think my squidguard is not working..
    i set my default destination rule set to deny (juz to test it)
    but i can surf web..
    is there something that i missing ?
    but the service i check is on..
    squid and squidguard is on






  • Have you configured your browser to use the proxy?



  • do i need configure my browser to use the proxy?
    my boss gave me this project to prevent staff from accessing porn stuff..
    if ur suggestion to configure browser to use proxy and i must go to the everyone computer in my company and set the browser?
    i think it's not efficient.. is there any other way to solve this case?
    or i juz block based on IP address in rules?



  • Enable Transparent proxy in Squid



  • @dvserg:

    Enable Transparent proxy in Squid

    still the same.. i can browse.. any idea??
    i configure the squid only like this..
    is it wrong?




  • Possible view squid and squidGuard config's ?
    /usr/local/etc/squid/squid.conf
    /usr/local/etc/squidGuard/squidGuard.conf



  • do you mean like this?

    how do you see
    /usr/local/etc/squid/squid.conf
    /usr/local/etc/squidGuard/squidGuard.conf
    in shell ??
    sorry i'm newbie in freebsd this shell makes me crazy..

    12.txt
    13.txt
    14.txt



  • still the same.. [u][b]i can browse[/b][/u].. any idea??
    i configure the squid only like this..
    is it wrong?
    

    You can browse or you users ?
    I found this in you config

    src test2 {
    ip 122.200.14.67
    }
    ...
    acl {
    # 
    test2 {
    pass !in-addr !blk_BL_porn !blk_BL_warez [u][b]all[/b][/u]
    redirect ...
    rewrite test62
    }
    

    From ip 122.200.14.67 - you allow browse. All any - no



  • i'm the one who configured it.. and i test it..
    the illustration like this

    my PC –--->PFsense------>switch-----> router

    when i browse i'm act as a user.. before i'm implementing it..

    i already set the deny rules
    see the picture above
    is there any error on my log?




  • Also if you setup browser proxy options  - what behavior with blocking ?



  • @dvserg:

    Also if you setup browser proxy options  - what behavior with blocking ?

    i wanna test the squidguard is working.. so i deny all as the default..
    if my default is deny then it must be block anything right..
    but i still can browse..
    or i should reinstall sg and squid and installed it again?
    hey if you don't mind can u PM me ur printscreen squid+squidguard
    i'd like to see it..
    i'm affraid that i misconfigure about the squid..
    and sorry if it's bother you..



  • Try this pls

    • disable transparent mode in squid, disable squidGuard
    • set you brouser Proxy options as squid configured (ip/port)
    • test http browsing = must work
    • enable SG, remove all ACL's, Default page set [all Deny], disable safesearch, Apply
    • test HTTP browsing - must be nothing.


  • @dvserg:

    Try this pls

    • disable transparent mode in squid, disable squidGuard
    • set you brouser Proxy options as squid configured (ip/port)
    • test http browsing = must work
    • enable SG, remove all ACL's, Default page set [all Deny], disable safesearch, Apply
    • test HTTP browsing - must be nothing.

    thx for ur answer but when i configure like u said i have a problem..
    when i set proxy..
    it cannot connect to internet..
    plz see the picture below
    any idea where it might be wrong??
    thx again










  • Why enabled squid upstream proxy? Squid has parent proxy server ?
    And you browser must be set to squid IP/Port, but not to upstream proxy setting.



  • @dvserg:

    Why enabled squid upstream proxy? Squid has parent proxy server ?
    And you browser must be set to squid IP/Port, but not to upstream proxy setting.

    thx.. it's worked.. it's blocked everything.. even i tried to change the default rules to allow all traffic..  ???

    but how to enable the transparent proxy server..
    so if client want to access website with port 80 they go to proxy server..
    cmiiw if i'm using transparent proxy it means i don't need to setup the browser proxy right?

    i already setup the like this but it's blocked all traffic..
    thx dvserg







Log in to reply