Cannot access public FTP



  • Hello,

    I am trying to access ftp.dd-wrt.com from inside my LAN (pfsense as my firewall). It will not connect, however, if i connect via my cell service then it works. I tried to ping ftp.dd-wrt.com from the diagnostics screen in pfsense and i get:

    PING download1.dd-wrt.com (185.84.6.100): 56 data bytes

    --- download1.dd-wrt.com ping statistics ---
    3 packets transmitted, 0 packets received, 100.0% packet loss

    Everything else is working ok. Is there something i need to do in config to access FTP sites?

    Jon


  • LAYER 8

    i think you need FTP_Client_Proxy
    it's a package that you can install from System / Package Manager
    after the installation you find it under services, it need to be configured and enabled, it's very easy but if you have any trouble just ask here again


  • LAYER 8 Global Moderator

    Works just fine here without the ftp package - that package is only needed if your going be wanting to use active.. Just connect with passive..

    ftp.png

    Works just fine with nothing having to be done with pfsense when using passive..

    active will not work, but when you use passive for the data channel

    Response:	257 "/Documentation" is the current directory
    Command:	TYPE I
    Response:	200 Switching to Binary mode.
    Command:	PASV
    Response:	227 Entering Passive Mode (185,84,6,100,129,35).
    Command:	LIST -a
    Response:	150 Here comes the directory listing.
    Response:	226 Directory send OK.
    Status:	Directory listing of "/Documentation" successful
    

  • Netgate Administrator

    You would also need the package if you are passing only specific ports on LAN rather than the default allow-all there.

    However that IP does respond to ping for me so you might have some other routing issue there.

    Steve


  • LAYER 8 Global Moderator

    @stephenw10 said in Cannot access public FTP:

    if you are passing only specific ports on LAN rather than the default allow-all there.

    Very true... If your doing such a thing you have to SAY that when you first post.. This is not something would assume your doing.. For starters anyone doing such a thing should have the basic skill set to troubleshoot something as simple as ftp ;) And normally wouldn't even be here asking such a question.



  • All,

    Thank you for your responses. After trying various things you suggested i figured something wasn't right - i removed all my rules to default and FTP connection worked right away. I do not know why FTP didn't work yet other things from LAN->WAN did but i guess i will learn these next few months.

    Appreciate the support - thank you

    Jon


Log in to reply