[Solved] No "Bandwidth In" after updating from 2.3.4 to 2.4.4



  • Hello,

    I've updated my perfectly working 2.3.4 to 2.4.4 just because it was "getting old".

    I have a DSL connection via a modem in "bridge mode" to the WAN port configured with PPPOE, then I have the LAN port to serve my home network, in addition I have the MODEMACCESS network to access back the modem.
    Pretty standard and pretty solid since years with 2.3.4 version of pfSense.
    Then I've decided to upgrade to the latest pfSense version 2.4.4: before that I've backed up the XML configuration, then installed from scratch the system on the same machine, configured pfSense as brand new and then restored the XML configuration from the 2.3.4 version.

    The issue is that I have NO incoming traffic, none of the network clients are able to connect to the Internet and in the Traffic Graph I see ALL CLIENTS "Bandwidth In" stuck to "0.00 Bits/sec". The "Bandwidth Out" have some traffic. Very occasionally I see some small amount of traffic from "In" direction to one or two IP.
    PPPoE is successfully connected with no errors in the log, strange enough pfSense is able to detect that "is on the latest version" and the "Dynamic DNS client" is correctly updating the WAN IP. So it seems to me that the pfSense box itself is able to send and receive traffic but there is something that blocks the LAN clients to receive data.

    I've also tried to setup (again) 2.4.4 from scratch on the same machine and setup the WAN and LAN manually without restoring the XML configuration. SAME result: PPPoE ok, pfSense box getting traffic but LAN still with no incoming data.

    I've tried a different modem and also the same tests by installing pfSense 2.4.4 in a different hardware. Still same problem.

    The only solution found is to install back the version 2.3.4, then restore the XML configuration and that's it. Working perfectly again.

    Any idea?

    Thanks.

    Franco


  • Netgate Administrator

    If pfSense itself is able to get out and clients on LAN are able to reach the webgui then it sounds like pfSense is not routing or maybe not NATing the traffic.

    Check pfSense can ping out by both IP and URL from Diagnostics > Ping. Check it can do so successfully using auto and LAN as the source.

    Do you have a gateway set on the modem access interface? I suspect you may do and that changed gatway handling in 2.4.4 is setting it as the default.
    Make sure the PPPoE gateway is set as the default v4 gateway in System > Routing.

    Steve



  • Hello,

    yes, it was the gateway!

    Here the 2.3.4 Gateway page:
    2020-01-03 12_25_09-Window.png

    And here the same page on 2.4.4, just after the restore of XML configuration backup:
    2020-01-03 12_23_50-Window.png

    I've "saved" the ipv4 and ipv6 gateway detail pages to "refresh" it, but nothing happened, the default was still pointing to the MODEMACCESSGW, I had to manually select the default gateway IPv4 to WAN_PPOE to make it work.

    Here how is it right now in 2.4.4:
    2020-01-03 12_58_07-Window.png

    Is this the proper way?

    Thank you so much for the support.

    Franco


  • Netgate Administrator

    Yup, that looks correct. Glad that solved it for you.

    Steve


Log in to reply