Successful upgrade and IPSec VPN multi subnet / phase 2 support



  • All - I am not a very technical user, I just know enough to be dangerous. My office is moving shortly and our new location has a new SonicWall unit up and running. In the meantime, we had to connect to another company for a quick and dirty IPSec connection which we will use the SonicWall for in our new location. Enter pfSense.

    Wow this thing is awesome - we successfully connected to a Cisco ASA box via IPSec following the guides on here. Our only hangup was that the other company needed us to connect to 2 different subnets over the single VPN connection which didn't seem to be possible in the release version of pfSense.

    On a whim I decided to try an in-place upgrade to the Alpha 2.0 version. Now bear in mind our setup is VERY simplistic. Firewall rules = BLOCK EVERYTHING except IPSec from our partner's public IP. pfSense is running on a boring old Dell desktop with 2 Intel NIC's, one connected to a bonded T1 (3mpbs) and the other to a DMZ on our internal network. The in-place upgrade worked flawlessly (I even did it remotely just to see what would happen.)

    After the reboot, I quickly figured out how to add our second subnet using the new "Add Phase 2 setting" within minutes we were up and running connecting to everything we needed to see.

    What a great product this is, and thanks to all who post on here and to the developers and all involved.



  • Thanks for sharing your experience. I'm glad everything worked out for you but still take care when using Alpha software in a production environment.


Log in to reply