Sierra Wireless MC8790 on apu2c4



  • Has anyone been able to get Sierra Wireless MC8790 to work on apu2c4?

    The modem is recognized by the OS:

    ugen1.3: <Sierra Wireless, Incorporated MC8790> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (0mA)

    However, I'm getting this in the ppp logs:

    Dec 24 12:44:02 ppp: [wan_link0] CHAT: The modem is not responding to "AT" at ModemCmd: label.

    Thanks!


  • Netgate Administrator

    How many ports are created? What have you tried?

    Before you setup the ppp link try connecting to the ports using cu and see which responds to AT.

    Steve



  • cuaU0.0 through cua0.6

    [2.4.4-RELEASE][xxx@xxx/root: cu -l /dev/cuaU0.0
    Stale lock on cuaU0.0 PID=15734... overriding.
    Connected

    and it just hangs. I suspect it might just require a specific init string...


  • Netgate Administrator

    You will have to make sure nothing else has it open. Disable/remove the PPP connection you have setup and reboot to be sure.

    You might want to specify the connection speed there too.

    Sierra devices don't usually require any init to respond there. Has that modem ever worked though?

    It might be stuck in a mode where none of the ports are AT. Though with 7 exposed that seems unlikely. All are no response?

    Steve



  • Deleted the PPP connection and rebooted. No change, I'm able to connect to all 7 but the connection just hangs on all of them (connection speed?). I got the modem on eBay, it's new but I can't tell if it's ever worked.


  • Netgate Administrator

    Usually you wouldn't have to select the baud there but if it's been changed in the modem perhaps you might.

    The first thing I would do here is load it with some other OS and check it's not dead and responds on some port. From there you may need to change it's setup to present an AT port to FreeBSD/pfSense, the usb composition.

    Steve


Log in to reply