Issue with VLAN



  • I have watched several videos and the answer is evading me. I have ubiquiti edgeswitch lite (24 port) with port 24 as trunk port. The default network is (example) 192.168.10.1/24.
    I created a VLAN (VLAN 20) using switch ports 17 and 18.
    In the PfSense appliance I created the VLAN20 with IP of 192.168.22.1/24 and enabled DHCP.

    This works fine.
    I now want to add a wifi VLAN (Using Ubiquiti UAP-AC-Lite which sits on port 2 of the edgeswitch.
    Within the unifi controller, I created a second network with VLAN ID of 22 and then created Wireless VLAN 22.
    I can see the wireless network, and connect, but I cannot gain network access which is odd since the two computers pull an IP and are allowed internet access. I am certain the firewall rules are fine, as I tried the VLAN with just an "any / any" rule, and with the others I normally add.

    If this is in the wrong place please let me know. And, if anyone can shed light on what I have messed up I will appreciate that also.
    I am attaching 3 pics to show settings, so I hope they are visible

    ![alt text](unifi-wifi-network.png network-unifi.png edgeswitch-VLAN22.png image url)


  • LAYER 8 Global Moderator

    Do you have a typo - why are you saying vlan 20 in pfsense, and vlan 22 on your unifi stuff?

    You prob get better support on how to do unifi vlans over on the unifi forums.



  • yes is typo,, VLAN is 22
    Have posted this in unifi forums as well

    Thanks


  • LAYER 8 Global Moderator

    I run vlans on my unifi AP, but I don't have any of their switches.

    If your untagged clients in 22 are getting IPs from vlan 22 dhcp server then your trunk to pfsense carrying 22 and your normal lan (untagged I assume) is working

    Your wireless looks fine with vlan set to 22 on that ssid.

    But I don't see why your setting networks in your controller - do you have a USG as well as using pfsense?



  • I have a similar setup only with unifi switch and not edge switch and unifi APs

    I have a VLAN 20 on my setup which is up and running which I configured last night.

    Your Network configuration however is different. I selected VLAN only since pfsense was handling all my DHCP functionality. I see in your Network setup VLAN only is greyed out and says USW required (which I don't know what that means). In terms of DHCP mode, have you tried just setting it to None.

    Did you setup a DHCP server on pfsense for the LAN within Pfsense. I terms of your Edge switch, it seems like you've setup your trunk port appropriately (I would guess - I've never used an edge switch).


Log in to reply