DNS Resolver not resolving one specific host (Three UK Wifi calling address)



  • Hi,
    I've been having some issues with Three UK wifi calling, I've tracked down the issue to the DNS resolver not being able to resolve this address epdg.epc.mnc020.mcc234.pub.3gppnetwork.org

    From a client on my home network I get SERVFAIL doing a dig

    stevetozer@Steves-MacBook-Air:~$ dig epdg.epc.mnc020.mcc234.pub.3gppnetwork.org
    
    ; <<>> DiG 9.10.6 <<>> epdg.epc.mnc020.mcc234.pub.3gppnetwork.org
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 2635
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;epdg.epc.mnc020.mcc234.pub.3gppnetwork.org. IN A
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.50.1#53(192.168.50.1)
    ;; WHEN: Sat Jan 04 13:49:38 GMT 2020
    ;; MSG SIZE  rcvd: 71
    

    When doing a dig against CloudFlaire DNS servers I get a reply as expected

    stevetozer@Steves-MacBook-Air:~$ dig epdg.epc.mnc020.mcc234.pub.3gppnetwork.org @1.1.1.1
    
    ; <<>> DiG 9.10.6 <<>> epdg.epc.mnc020.mcc234.pub.3gppnetwork.org @1.1.1.1
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63671
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 1452
    ;; QUESTION SECTION:
    ;epdg.epc.mnc020.mcc234.pub.3gppnetwork.org. IN A
    
    ;; ANSWER SECTION:
    epdg.epc.mnc020.mcc234.pub.3gppnetwork.org. 1753 IN CNAME epdg.epc.wip.mnc020.mcc234.pub.3gppnetwork.org.
    epdg.epc.wip.mnc020.mcc234.pub.3gppnetwork.org.	0 IN A 188.31.254.71
    
    ;; Query time: 17 msec
    ;; SERVER: 1.1.1.1#53(1.1.1.1)
    ;; WHEN: Sat Jan 04 13:51:08 GMT 2020
    ;; MSG SIZE  rcvd: 114
    

    Via shell on pfsense directly I also get a reply

    [2.4.4-RELEASE][admin@pfSense.ihouse.local]/root: host epdg.epc.mnc020.mcc234.pub.3gppnetwork.org
    epdg.epc.mnc020.mcc234.pub.3gppnetwork.org is an alias for epdg.epc.wip.mnc020.mcc234.pub.3gppnetwork.org.
    epdg.epc.wip.mnc020.mcc234.pub.3gppnetwork.org has address 188.31.252.71
    

    Not sure if theres a setting I need to change on the DNS Resolver to fix this

    Thanks
    Steve


  • LAYER 8 Global Moderator

    hmmm..

    Seeing the same servfail here... Let me take a look for a bit.

    edit: Strange I didn't do anything and now is resolving

    $ dig @192.168.9.253 epdg.epc.mnc020.mcc234.pub.3gppnetwork.org
    
    ; <<>> DiG 9.14.7 <<>> @192.168.9.253 epdg.epc.mnc020.mcc234.pub.3gppnetwork.org
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4998
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;epdg.epc.mnc020.mcc234.pub.3gppnetwork.org. IN A
    
    ;; ANSWER SECTION:
    epdg.epc.mnc020.mcc234.pub.3gppnetwork.org. 3378 IN CNAME epdg.epc.wip.mnc020.mcc234.pub.3gppnetwork.org.
    epdg.epc.wip.mnc020.mcc234.pub.3gppnetwork.org. 3574 IN A 188.31.254.71
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.9.253#53(192.168.9.253)
    ;; WHEN: Sat Jan 04 08:34:51 Central Standard Time 2020
    ;; MSG SIZE  rcvd: 114
    

    edit2: yeah they seem to have some issues to be honest

    theyhaveproblems.jpg



  • Thanks for talking a look, I've done a quick google and seems Cloud Flare had a similar issues then they released the 1.1.1.1 dns servers when trying to resolve these addresses

    I’m just looking into this, thanks for your patience. It seems that the NSs at wip.mnc020.mcc234.pub.3gppnetwork.org are broken for QNAME minimisation, as they don’t respond to anything besides the full name. I’ll add overrides for this NS set in the next upgrade.
    

    https://community.cloudflare.com/t/wifi-calling-not-working/14712/28

    Looks like i'll have to forward my dns requests to CF to get this working.

    Steve


  • LAYER 8 Global Moderator

    Your not using minimization are you? I don't have it set... To be honest they are broken, more than minimization issues... see info produced when testing..

    But sure if whatever outside ns resolves them for you, you can do a domain override for that domain.

    But don't be surprised when that fails sometimes too...



  • Not using minimization,

    I've set a domain override for that now so it uses 1.1.1.1, it resolves but its really slow see below how long it takes to resolve (Query time: 2051 msec) compared to doing a dig directly to 1.1.1.1 (Query time: 17 msec)

    stevetozer@Steves-MacBook-Air:~$ dig epdg.epc.mnc020.mcc234.pub.3gppnetwork.org
    
    ; <<>> DiG 9.10.6 <<>> epdg.epc.mnc020.mcc234.pub.3gppnetwork.org
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25550
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;epdg.epc.mnc020.mcc234.pub.3gppnetwork.org. IN A
    
    ;; ANSWER SECTION:
    epdg.epc.mnc020.mcc234.pub.3gppnetwork.org. 2677 IN CNAME epdg.epc.wip.mnc020.mcc234.pub.3gppnetwork.org.
    epdg.epc.wip.mnc020.mcc234.pub.3gppnetwork.org.	1 IN A 188.31.254.71
    
    ;; Query time: 2051 msec
    ;; SERVER: 192.168.50.1#53(192.168.50.1)
    ;; WHEN: Sat Jan 04 15:35:46 GMT 2020
    ;; MSG SIZE  rcvd: 114
    

    Thanks for all your help with this


Log in to reply