Problems (running on WRAP and trying to migrate to PC)



  • I am currently running pfSense 1.2.2 on WRAP (embedded) platform.  I have a pretty extensive rule base and quite a few aliases setup.

    I have been running into a problem where the WRAP system reboots if the network interfaces get flooded.  My WRAP system has 3 10/100 interfaces.  Most of my machines have 10/100/1000 interfaces and all of my switches support 1000Mb.  When I copy a large file (700+ MB) between two of the systems on different interfaces off  of the WRAP, the WRAP (pfSense) system reboots.

    Because this is becoming more of an issue for me, I decided to try migrating to the PC (full) version of pfSense.  I setup a new system with a quad Ethernet card and installed the 1.2.2 version of pfSense on it.  I backed up my configuration (through the GUI) on my WRAP system and loaded it on the PC.  I had to reassign my network interfaces and everything seemed ok at first glance.  However, upon closer inspection, most of my rules and all of my aliases were missing.

    Has anyone tried this before, and is there any way to get all of my rules/aliases/etc. migrated properly between the two platforms?

    Alternatively, I would love to know if there is a fix to the rebooting issue I am having on the WRAP box.

    Any suggestions would be greatly appreciated.



  • @fmarinonj:

    Alternatively, I would love to know if there is a fix to the rebooting issue I am having on the WRAP box.

    Have you tried pfSense 1.2.3? see http://blog.pfsense.org/?p=377 and http://blog.pfsense.org/?p=428 Perhaps the improved hardware support in FreeBSD 7.1 will fix your problem.



  • So far, 1.2.3 seems to have fixed my reboot issues.  :D

    I have not tried the migration to PC (full) yet to see if the config comes over ok, but as long as the reboot issues are fixed, I don't need to go this route.

    Thanks for the suggestion.



  • If you have a WRAP and not the newer ALIX try turning on polling.  In load testing I saw the same issue with the WRAP boards and enabling polling helped quite a bit.

    ssh to the pfsense.  Select 8) Shell.

    sysctl kern.polling.enable=1



  • I tried enabling polling to see what difference that might make.  I noticed about a 50% decrease in throughput with polling enabled.  Transfers across the WRAP box went from about 2MB per second down to 1MB per second.

    For now, I will keep polling disabled and see if I have any issues with the new version.  So far, it has been working great.  ;D

    Thanks again.


Log in to reply