Need help configuring



  • I am trying to recreate our Hyper-V environment after a server crash. All the VMs except one haves been recreated and are running fine. The only one that was totally destroyed was a VM with a pfsense router, an old one, I think it was 2.1.something. I thought, no problem, created a new VM and installed a fresh pfsense 2.4. I can't get it to work, and my understanding of routing, DNS, etc. is very limited.

    I have assigned IP address and upstream GW to the WAN interface and 192.168.0.1 to the LAN interface (like it was before). 192.168.02 is assigned to a windows SBS 2011 configured to use 192.168.0.1 as a gateway. The SBS 2011 server is running its own DNS server. All the client machines on the private network get their IP addresses assigned by the SBS DHCP and uses 192.168.0.2 as their gateway.

    I have disabled the firewall in pfsense and tried to understand how to configure the DNS settings. The more I Google on the subject the more confused I get. I can't get Internet access to the server, it says it can't find the DNS.

    The old setup worked fine but no backup available :-(

    HELP!!



  • First turn the FW back on immediately. You are sitting on the Internet wide open.



  • @HW said in Need help configuring:

    I can't get Internet access to the server, it says it can't find the DNS.

    Please clarify this. No access to internet and can't find DNS are not the same.

    Can you ping 8.8.8.8 from the SBS server?
    If yes, then you have access to internet. If not, then you have no access to the internet.

    If the above worked, can you ping google.com?
    If yes, then you have DNS resolution. If no, then you do not have DNS resolution.

    If the 8.8.8.8 ping worked, but the google ping did not work, check the pfsense docs on DNS resolver.
    https://docs.netgate.com/pfsense/en/latest/book/services/dns-resolver.html

    I don't think it's necessary to disable the firewall. I'm not even sure what you mean by that. Disabled NAT? Disabled the default allow all rules? In fact, that may be your issue. By default all traffic out going of the network is allowed, including DNS traffic. Whatever you did to disable that, could have caused your issue. Try going back to all defaults from a fresh install. Then what are the ping results from the server?



  • OK. Enabled the firewall and can ping both 8.8.8.8 and google.com. But still mail isn't working and not possible to reach the Remote Desktop Gateway from outside.



  • All working now. Just learned about port forwarding. Created rules for port 443 and 25 and now it is all working again.

    Thanks for pushing me in the right direction.



  • @HW said in Need help configuring:

    OK. Enabled the firewall and can ping both 8.8.8.8 and google.com. But still mail isn't working and not possible to reach the Remote Desktop Gateway from outside.

    Good to hear it's working. Don't forget to backup the configuration this time! Diagnostics > Backup & Restore.

    I hope you're not using remote desktop into your network without encryption. That's not the best practice.


Log in to reply