Git won't install on pfSense developers ISO build


  • I followed the instructions on DevelopersBootStrapAndDevIso, using the developers ISO build, however, it hangs at the end of the git installation and showing errors in lock_remote, remote_ls, and locking_available. gmake gives the final error message as [http-push.o] Error 1.

    Is the DevelopersBootStrapAndDevIso current for the most recent pfSense developers ISO build? Am I missing something here?

    Any help would be greatly appreciated.


  • Maybe my original question wasn't all that clear. Has anyone used the instructions in DevelopersBootStrapAndDevIso on the pfSense developers ISO build, more recently? If so, are the instructions still accurate with regards to the v1.2.2 version of the pfSense developers ISO? Are there additional steps that i need to accomplish to make this thing work.

    Any help with this matter would be greatly appreciated.

    As a final thought… Does anyone have a pfSense Developers ISO with ports and GIT already installed?


  • I had the same problem with git. It appears that expat is not installed in the pfSense 1.2.2 developer's ISO. Installing expat from ports worked for me.

    cd /usr/ports/textproc/expat2
    make install clean

    Once expat was installed I was able to build and install git without any other problems.

    Hope this helps.

    -Chris


  • Thank you! I'm going to give it a shot right now.


  • My apologies for taking so long to confirm that your suggestion worked. It worked. Thank you very much. Your assistance is greatly appreciated.


  • No worries. Glad I could help  :)


  • I followed the instructions on DevelopersBootStrapAndDevIso, using the building a custom pfSense image, however, it says command not found soon after I enter command ./cvsup_bsdinstaller.sh

    Is the DevelopersBootStrapAndDevIso current for the most recent pfSense developers ISO build? Am I missing something here?

    Any help would be greatly appreciated.