Enable 802.1q VLAN mode via Shell Access



  • Hello,

    I am trying to enable this checkbox via Shell on the XG-7100 device (it was unchecked and as a result the device lost connection). What is the command for accomplishing this?

    alt text

    Thanks.


  • Netgate Administrator

    If you just unchecked it it's probably easier to roll back the config from the console menu.

    You can set it temporarily using etherswitchcfg but that would not restore the default vlan and port config. You could also set that using etherswitchcfg but it gets complex.

    When you set or unset that in the webgui some default values are applied. There is no way to replicate that exactly from the cli.

    Steve



  • I ended up using option 15 to restore from a recent config as running etherswitchcfg vlan_mode DOTQ did change the cfg, but the device was still unaccessible so restoring was the only option.

    0) Logout (SSH only)                  9) pfTop
    1) Assign Interfaces                 10) Filter Logs
    2) Set interface(s) IP address       11) Restart webConfigurator
    3) Reset webConfigurator password    12) PHP shell + pfSense tools
    4) Reset to factory defaults         13) Update from console
    5) Reboot system                     14) Enable Secure Shell (sshd)
    6) Halt system                       15) Restore recent configuration
    7) Ping host                         16) Restart PHP-FPM
    8) Shell
    

    /Closed


Log in to reply