Zotac CI323 Nano hdac0 Interrupt Storm Mitigation



  • Hello,

    In case this may help someone else, I noticed unusually high CPU usage following my upgrade to 2.4.4, and top showed that it was due to a very high rate of interrupts from hdac0. To be quite honest, I'm not certain that this coincided with the 2.4.4 upgrade, or if I've just been so oblivious that I never noticed until now. But since hdac0 is just Intel HDA Audio, and therefore of no particular use to a firewall, it can be disabled by adding the following line to /boot/loader.conf.local:
    hint.hdac.0.disabled=1

    Regards.



  • @Ramirez47

    Another option (probably?) disable audio in the BIOS/UEFI.

    I always disable Audio in my pfsense systems including my CI323 at the BIOS level along with other unused stuff, such as COM ports ( i don't have a need for them some might) and things.


Log in to reply