ALTQ compatible hardware?



  • I haveh a question regarding the NIC drivers and NIC types for using traffic shaping.  I have tried combinations of the following cards and I always get an error that my LAN or WAN does not support ALTQ.

    3Com 905c-TX 10/100 Mb - xl
    3Com 900B 10 Mb - xl
    Intel based compaq card 10/100Mb - fxp
    C-Net Pro 200 - 10/100Mb - dc

    As far as I have read, ALTQ should be supported in all of the above drivers.  Is there something I am missing?

    Any help would be greatly appreciated.



  • The following interface types are ALTQ compatible:

    “an”, “ath”, “awi”, “bfe”, “bge”, “dc”, “de”, “ed”,
    “em”, “fxp”, “hme”, “lnc”, “ndis”, “rl”, “sf”, “sis”, “sk”,
    “tun”, “vr”, “wi”, “xl”, “vlan”, “ste”



  • Thanks for taking the time to reply, but I am still kinda’ stuck here.

    Based on your answer above am I to assume that either:

    a) It is a cosmetic error; ALTQ is really functioning (since I am using cards and drivers that are supposedly supported) but the error in the GUI is incorrect and a bug?

    b) ALTQ is not currently functioning and is a bug that will be corrected in the future or possibly……

    c) My particular cards are not 100% compatible with the ALTQ functions in the modified xl, dc and fxp drivers?

    I’m currently using the .90a upgrade that was released and I understand that it’s in an alpha state.  I’m mainly trying to find out if I should look at picking up some different NIC’s even though mine are supposedly supported or I just have to wait for the development cycle to get a bit more in the beta/rc phase.

    Thanks again



  • Please add some info about what errors you get, and how you encountered the problem, ALTQ shoud work fine.



  • What version of pfSense and what kind of WAN do you have? If you have PPPoE your WAN-connection is not the NIC itself but the PPPoE-connection. There have been older versions of pfsense that had PPPoE-drivers without ALTQ-support. If you are not running the latest version please upgrade and retry.



  • Thanks guys, I was running .90a as an upgrade from a previous version and I just now installed .92, fresh.  ALTQ appears to not be giving me errors now.

    Thanks again, I thought I was losing my mind as it worked in the past just fine.



  • Will there ever be support for AXE?



  • @cybrsrce:

    Will there ever be support for AXE?

    ALTQ-capability of the driver itself is an driver issue. You would have to ask the drivermaintainer for that.


Locked
 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy