Tried to change LAN ip, now unable to login pfSense



  • I changed LAN ip address (192.168.1.1 -> 192.168.77.1) on WebGUI. Before pressing "Apply" on interface-page I checked if DHCP-server tab gave opportunity to addjust DHCP-range, but whole LAN-section there had disappeared. Next went back interfaces and pressed "Apply". Since that I have not managed to connect pfSense. DHCP server is down. I have tried manually setup ip-address to both 192.168.1.x and 192.168.77.x -ranges, but with no luck (eg. ping is not working).

    I never checked console output while everything was ok, but now I wont see any suspicious here: pfsense console.txt. Why there is no normal Console Menu (https://docs.netgate.com/pfsense/en/latest/book/config/console-menu-basics.html)? Is there any other option than reinstall?

    Thanks! I have no idea what mistake I made.



  • That boot is not complete, how long did you wait while connected to the serial console?
    The two things I noticed are 1) You don't need to plug a keyboard into an APU, and 2) You can get by with a much smaller, cheaper msata than that one. I typically use a 32 gb.


  • Netgate Administrator

    That is the last thing you would see if it's using vid console as primary console though. And doesn't complete the boot for some reason; the menu usually appears on all configured consoles.

    You can probably force serial to be primary and then see what the error is. It's probably an interface mismatch.

    https://docs.netgate.com/pfsense/en/latest/hardware/boot-troubleshooting.html#booting-with-an-alternate-console

    Steve



  • I made first hard reset before connecting console. Mayby I managed corrupt media? I have now rebooted machine couple of times, but it always stops this same phase; nothing have happened in 2 hours.

    1. external keyboard is only for soft reset (ctrl-alt-del), there is probably way to press this same on my windows-laptop-console, but external keyboard was just easier choise
    2. that msata is 32gb, 25 € or something..


  • TIL- you can reboot a PCEngines APU2 via USB keyboard.
    I tried this, and the OS does seem to reboot cleanly after a single C-A-D, and doesn't just dump the box like pulling the power would.



  • I tried to apply those boot options, but I think I have some problem with my terminal. Some menu options on boot menu work, but for example [Esc]ape needed for loader prompt is not activating at all. Even working menus are really slow. Is it possible I have some cable or terminal emulation issue? I used some other terminal machine + client when installing system and it was normal. Now it is IBM T23 + Tera Term.


  • Netgate Administrator

    Yes you might have a bad cable or bad terminal setup. Hardware flow-control that has no wires existing can result it no input to the appliance.

    Can you enter Coreboot setup (F10 for boot menu)? That would prove your terminal setup.

    Steve


Log in to reply