TLD issues/questions....



  • I currently have an at home/home brew box 16Gb ram Intel quad core 3.5 Ghz processor and an Intel Pro 10/100/1000 PCIExpress card basic setup.

    PfBlocker is setup and running great, i read and saw some places to enable TLD, so i give it a shot!

    Once enabled it immediately maxes 16Gb of ram and system is unresponsive enough that i tried a reboot and it still is locked up so much the buzzer sounds like its dying trying to do the startup sound...halarious.

    So i reinstalled PfSense and restored my backup and tried again ...same issue. Am i missing something or is this setting meant for a bad ass rack mount system?



  • @whizatit Logs are always helpful in understanding your issue. It seems that something is wrong with your configuration...so, post logs!



  • Can't retrieve/post logs if system freezes :-(

    I cant even log into the GUI/on the box itself it just locks up entirely!

    EDIT:
    Default pfblocker load with GeoIP enabled and setup, IP settings in shalalist and UT1 setup for the bad stuff (porn, pishing, Dangerous kits, etc of the like) and thats it.

    EDIT EDIT:
    I was under the assumption checking TLD was the only option unless you blacklist/whitelist a site.



  • @whizatit Did you installed pfBockerNG-dev? If not, that's what you need.



  • @NollipfSense yes sorry should've mentioned it's the dev version



  • Really nobody has ANY thoughts? I guess an actual forum might be more helpful...



  • @whizatit You may not want to hear this however, your solution is a clean install and reconfigured...do not restore from backup configuration.



  • @NollipfSense I did multiple times same issue, changed processor and ram just for the hell of it thinking one of the two could be bad to no avail.



  • @whizatit I don't know what else to say other than you might have blocked ten million domains or more since it consuming all your available RAM to the point that your system freezes. Did you enable all in the shallalist? You have 16GB RAM...2.5 million domains will occupy 7GB RAM...see image below!

    Screen Shot 2020-02-01 at 12.47.58 PM.png



  • @NollipfSense no only bad stuff such as porn, redirectors, ads, proxies and the like are enabled only, I have a total of 21 enabled in both lists together.👍

    DNSBL is enabled with Block on all top offenders/Deny Inbound on most everything else.

    Dont host but have a multitude of devices in home for automation that have been attacked in the past, cameras, gate openers, etc etc most ALL attacks came from Russia.



  • OK question, is there a way to see the lists i checked, how many per list i select, there are in the said list?

    Is there a site/sites per list to check the amount of blocked sites/domains?



  • @whizatit said in TLD issues/questions....:

    Can't retrieve/post logs if system freezes :-(
    I cant even log into the GUI/on the box itself it just locks up entirely!

    Can you access the box using the Console or SSH ?
    From there you can inspect the logs.



  • @RonpfS nope totally locked up not even serial just shows gibberish.



  • @whizatit And when it boot does it only show gibberish?



  • @RonpfS after post it takes about 5 seconds then it's locked up



  • I guess it's time to start over without pfblocker to see if the system is stable.



  • System is stable always until TLD is enabled reload or not.



  • Post some debug info here then we can see what is going on.

    What others package are you using ? What pfsense version? What is your DNS services setting? What is your network configuration?

    Before enabling pfblockerNG, inspect the system logs, resolver logs, pfblockerng logs to see if something is broken.

    Then enable only pfblockerNG , DNSBL disabled, inspect the pfblockerng logs during a Force Update and Force Reload All.

    Enable DNSBL without TLD, with only one DNSBL group enabled, enabling more until something break.

    Inspect the logs, how many domains are used etc.



  • @whizatit I find it baffling that you installed a clean new copy of pfSense that works, then you added pfBlockerNG-dev and still worked, then you configured your list and checked TLD, force reloaded/update pfBlockerNG-dev and system freezes...it's not making sense...unless you have a hardware issue; and the suspect is RAM. However, you said RAM checked out good!



  • Also :

    @whizatit said in TLD issues/questions....:

    Can't retrieve/post logs if system freezes :-(

    That why logs shouldn't stay on the router.
    You have to 'backup' your logs. Because: if you have them, you wont need them - and the other way around.

    I've TLD selected since the beginning on a very old plain vanilla "Intel(R) Pentium(R) 4 CPU 3.20GHz
    2 CPUs: 1 package(s) x 2 hardware threads " with 2 GB.
    Four or five classic feeds ( DNSBL ).

    Here you can see memory and system resources (yep, another way to 'log' outside the box).

    pfSense freezes ? I don't recall freezing mine on me ...


Log in to reply