UPnP stopped working after upgrade to 2.4.5-RC

  • Hello,

    I upgraded to 2.4.5-RC and after that I noticed UPnP has stopped working.
    The miniupnpd service is running and the logs show no errors.
    Everything looks fine and no settings have been changed after or during the upgrade.
    Only the UPnP list stays empty and ports are not getting forwarded.

    2020-02-02 10_44_54-CHRIS-PFS.phobos.lan - Status_ UPnP & NAT-PMP.png

    Any idea what can be the issue here ?

  • Rebel Alliance Developer Netgate

    Does your WAN have a public or private IP address?

    I'm not sure if it's a recent change, but one thing I have noticed lately is that miniupnpd will not create forwards if the WAN address is a reserved range like RFC 1918. It usually logs that, though.

    That said, I was able to fire up a test client behind a 2.4.5-RC system just now and it was able to make a port forward via UPnP, and it showed in the list.

  • My WAN interface indeed does have a private IP address ( This because my pfSense box get it internet connection via a fibre modem.
    I assume it must be a recent change if this is the case , because it has always worked with this setup in the past.

    However is it weird that with your test setup it has no issues then..

  • Rebel Alliance Developer Netgate

    I see why mine worked. I had manually set an external address, which bypasses the check. If your actual WAN address is static (or reasonably so) you could set that in the UPnP options as well.

    It doesn't look like the miniupnp folks are budging on it, and it isn't a recent behavior change: https://github.com/miniupnp/miniupnp/issues/298 -- Their "solution" is to let it use a STUN server to determine the external address, which is still not ideal.

Log in to reply