Last update— failure to boot



  • Whatever the last update took down my system

    I am not getting a dhcp address so I am trying to hook up a hdmi cable

    0E06BDA8-3693-47FA-9D7B-CD28C5B35B33.jpeg

    well i have my sg2220 as a backup device. sadly i can't restore a more recent backup as i can't get my device key because it won't BOOT!

    i tried for an hour to reimage the quad core minnowboard from netgate. but i need a windows pc apparently writing the USB drive from linux mint is not working



  • Try a filesystem check.
    Boot the box into the single user mode, at command prompt type

    /sbin/fsck -y /
    


  • i reinstalled the OS at work today early this morning,

    i'll restore a backup once i return home

    thank you for the reply



  • @bcruze said in Last update— failure to boot:

    Whatever the last update took down my system

    Actually, it was a dirty file system that showed it's nose when you rebooted, the latter was needed because you were updating.
    Run a fsck by hand ( command line of course, like PC / MAC / Li,nux like device) before doing major changes on your pfSEnse, like upgrading..... (although it will ask for a reboot if some cleaning is needed).
    The "dirty file system" never happens when you shut down your device the "proper way", and add a UPS in front of it that handle power outage problems.



  • this is on a APC 1500VA backup system.

    and i always halt the system the normal and expected way



  • Buy a loto today .... you're collection very rare things ^^


  • Rebel Alliance Developer Netgate

    Actually it wasn't a dirty filesystem, the GPT table was corrupted. That's outside of the filesystem, in the partition area. That is unlikely to have been damaged by anything that would cause filesystem problems. I'd suspect the storage medium is having a problem. A reinstall may have tickled the disk into relocating the problem sectors.



  • ok a reinstall fixed it as of now but i'll keep an eye out

    i may end up replacing the HD as this is just a year and a half old and has never lost power as its been on an APC

    this is a minnowboard from Netgate right before they were discontinued


  • Rebel Alliance Developer Netgate

    You might check the SMART data and see if anything looks worrying there, maybe run a long self test on the drive.



  • Extended offline Completed without error

    shrug

    i apologize i posted this under Dev. but this truely happened after a 2.4.5 dev update

    appreciate your teams work on Pfsense


Log in to reply