Can't bring opt2 interface up



  • Greetings All!
    I have an SG-2440, 2.4.4-RELEASE-p3, and I'm wanting to use the OPT1 and OPT2 interfaces. I started trying to set up a VLAN on OPT2, but have backed off to simplify and troubleshoot and now am just trying to get the interface to come up and provide DHCP. I've removed the VLAN configuration and re-configured the main interface and it's currently showing "no carrier" in the interface status.

    What I did was enable the interface in the gui, IPV4 connection type static, I set it's ip address as 192.168.68.1/24, and saved the config. I also went into the dhcp server config and enabled it for OPT2, as well as set the range for .100 - .254, and the DNS server to 192.168.68.1. I verified DNS Resolver is listening on All interfaces. I then set up a FW rule to pass TCP/UDP src: OPT2 net, dst: any.

    I plugged a laptop into OPT2 and can't pull dhcp. pfSense is showing the interface status as "no carrier". I've tried bringing the interface down and back up, but still same. Can anyone point me in the right direction?

    Thanks!



  • DOH! Gotta be either hardware issue or layer 8. :) I just tried same on OPT1 and it came right up. Back to the drawing board....

    Y'all have a great day!!



  • Still have a question though. If I'm setting up an OPT interface to have a VLAN on it, would I need to simply enable the parent interface, or would it need to also have an ip set on it?


  • Netgate Administrator

    You don't need to enable or even assign the parent interface.

    If you have, say, igb3.100 setup you can assign and enable just that VLAN.

    Steve



  • @stephenw10 Awesome, much thanks Steve!


Log in to reply