Upgrade backup router without interfering with existing router



  • Can someone direct me to info on how to upgrade a backup router & its pkgs connected behind an in service pfsense router without conflicts between both routers? Thanks.


  • Netgate Administrator

    Why would there be a conflict? If it's functioning currently just hit upgrade and it will come back up with the same non-conflicting settings. The usual precautions apply to upgrading of course.

    Or do you mean re-install where the default 192.168.1.0/24 subnet might conflict?
    In that situation you can use one of these methods to pull in the correct config during the install or at first boot:
    https://docs.netgate.com/pfsense/en/latest/backup/automatically-restore-during-install.html

    Steve



  • This post is deleted!


  • @stephenw10

    Trying to upgrade from 2.4.2 to current. I have an "in service" router with Wan fiber static ip credentials working fine. With the same credentials (matching config) if I connect the spare router behind the "in service" router (Wan <> Lan) the spare router's wan adapter won't route through the "in service" router obviously. A public ip can't communicate to a private ip. So I have to temporarily modify the spare wan to a static ip in the same subnet as the "in service" lan. Still get no internet, or GUI access, can only ping the lan. The two other adapters are configured as Vlans. Could not connecting the Vlan's to a switch cause the GUI to not be accessible? Wouldn't think so. Gonna try connecting via ssh port 24 to see if we can do anything that way. Perhaps we can disable the vlan adapters and disable rules to see if the GUI comes to life.

    I haven't found a way to conveniently upgrade the spare router off-line so still trying to get it connected to the internet. Difficult without GUI access. I'll post if I discover any other oddities that might narrow the search.



  • Have access to the router with ssh so restarted GUI from terminal session. Still no browser access so it's not a rule block issue as both methods use the same rules. Tried from two Pc's using two different browsers, so it's not a browser issue. Gonna try to find more FreeBsd commands to hopefully view the log to see if it reveals anything. Really stumped at this point.



  • Unbelievable! The technician wasn't browsing the correct URL. Was using port 80 not that assigned in the router. Ugggg. Nevermind this thread, established access.


  • Netgate Administrator

    Good to hear to got access at least. 😉

    That sort of situation can be inconvenient. There is no off-line upgrade option currently. You can upgrade from the console menu as long as you have a functioning WAN.

    You might consider switching to a full HA setup if you can get enough WAN IPs.

    Steve


Log in to reply