NAT reflection not working properly



  • Hello, I have nat reflection enabled, I followed the docs without adding anything, although I've chosen PureNAT for the record.

    The issue I'm having is that when I port scan my public ip from inside the network, I only get 3 open ports, 22, 53 and 80, even though the public IP I'm scanning should be going to a server with multiple ports, I can confirm that when I port scan from an online scanner or using an external network, all the ports show just fine.

    I even disabled NAT reflection on port 80 rule just to see whether it will not show in the scans anymore, but it's still there. Whether I add a new rule or delete it, it seems that I always get those 3 specifics ports showing. I checked almost everything.

    Anyone can think of what's going on here? Thanks a lot.



  • So are you saying you have other ports set up with NAT reflection but they're not working? Or that you get those three ports regardless of NAT rules you set up?



  • @teamits said in NAT reflection not working properly:

    So are you saying you have other ports set up with NAT reflection but they're not working? Or that you get those three ports regardless of NAT rules you set up?

    I get those three ports regardless of the NAT rules I set up.



  • Is there any rule that would allow access to pfSense's WAN from the LAN, maybe a floating rule?



  • @teamits said in NAT reflection not working properly:

    Is there any rule that would allow access to pfSense's WAN from the LAN, maybe a floating rule?

    None, I checked, no floating rules have been defined,



  • Still no clue on what's causing it, if anyone has an idea, it would be grand.


Log in to reply