Yet another "swap_pager_getswapspace" issue



  • Hi all,

    I am running a small dev system behind a pfSense. The system is sitting onVultr (https://www.vultr.com/). We do not have more than 10 concurrent connections. However, every once in a while, we get the infamous "swap_pager_getswapspace" error and we need to cold reboot the server to bring pfSense back to life. I have been tryig to find a pattern for the problem without much success.

    This is a 2.4.4-RELEASE-p3 (amd64) running on FreeBSD 11.2-RELEASE-p10 with 1GB RAM and 1GB of SWAP. During regular use we never see the memory usage going beyond 15%. I have seen many reports on the same issue but they do not seem to apply to my system. I am only running one IPsec tunnel + 1 OpenVPN servers with 3 concurrent connections and one servers behind pfSense. The server is a freeswitch handling around ten concurrent calls.

    I have read that some people advice in simply disabling the SWAP. Is that a sensible move? I would rather find what the heck is causing the spikes but I am at lost.

    Any idea is highly welcome!

    Thanks!


  • Netgate Administrator

    Generally if you're using SWAP something is going wrong. If you disable it you might see a different error that's more helpful in pinning down the issue at least.

    Steve



  • Thank you @stephenw10 for your reply. You are right. I will give it a try. Now I just have to find out the proper way to disable the swap, it seems some sorcery is needed. Thanks!


  • Netgate Administrator

    The best way is to remove the SWAP partition at install time. If re-installing is an option for you.


Log in to reply