Vlan over lagg



  • Dear all,

    Pfsense version: 2.4.4-p1

    ISP - (Wan) Pfsense (Lan [Lagg0]) - (LACP) cisco switch ( Internal network [vlan 1, vlan2....])

    1. Added Lagg0 in my pfsense and connected to my switch, the channel port in cisco can work fine.

    2. Add the vlan in pfsense Lagg0, the channel port in cisco change to down.
      1 Po1(SN) LACP Gi0/0(w) Gi0/1(w)

    Attached is my cisco configuration to you for reference:-
    interface GigabitEthernet0/0
    switchport trunk allowed vlan 1-3
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode active
    !
    interface GigabitEthernet0/1
    switchport trunk allowed vlan 1-3
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode active

    My question is can pfsense support Vlan over Lagg? Please advise.


  • Netgate Administrator

    Yes it can, that's a very common configuration.

    You should run the current version, 2.4.4p3, unless you have a very good reason not to.
    That should not cause a problem with this though.

    Steve


Log in to reply