PFSense notification settings



  • Re: Notification email settings. Allow STARTTLS option.

    Hey. Tried this last year, failed miserably. Turned off notifications. Recently decided to resolve all my pfsense issues. This one I managed to resolve on my own.

    I did not know that Google implemented an allow unknown devices signon recently - and I did not know it was turned off by default.

    I've been troubleshooting this for about an hour or so without actually checking the setting. Google sends me an email informing me that and unknown devices is trying to logon to my google account. I select the YES IT WAS ME choice and then delete the email. I received 5 or 6 emails like this and did the whole "Yes it was me" thing on each one before deleting the email. I believed by confirming it was me that google would disable the unknown device blocking. I was wrong. I went to my google account, click security and scroll down to the "Less secure app access" section.
    It is set to OFF - default
    Set it to on and try the notifications test again in PFSense - if PFsense notifications is configured correctly it should work fine.

    I created an email just for this, then forwarded the notification email from the gmail account I set up for notifications to my main account which is then filtered into a folder I created to receive the pfsense notifications.

    The To email, notification email, username are all the same because I am using gmail.

    My config
    pfsense_notifications.png



  • @1OF1000Quadrillion Your question isn't clear. Is it now working the way you want? The way Google account work has nothing to do with pfSense especially since you got emails you asked it to send to you.



  • Arhg - My apologies NollipfSense - I completely forgot about this post. Yes, I got it working, by turning on the "allow less secure devices to sign in" function in the google account settings page -> security, not the gmail settings.

    This was just a post for others as I was REALLY frustrated that this was not working in PFSense even though I was a thousand percent sure I had the exactly correct settings.

    Basically I wanted everyone to know that if it is not working for them using a gmail account, they would need to follow the above settings to "allow a less secure" sign in to the google account and to not look for it in their gmail settings. IS there a way to mark my own question solved?




Log in to reply