Error updating SG-1100 2.4.4_p3 to 2.4.5.r.20200226.2100



  • Hello!

    The update fails with the following error:

    7538588:error:14099006:SSL routines:ssl3_send_client_verify:EVP lib:/usr/local/poudriere/jails/pfSense_factory-v2_4_5_aarch64/usr/src/crypto/openssl/ssl/s3_clnt.c:3299:
    7538588:error:14099044:SSL routines:ssl3_send_client_verify:internal error:/usr/local/poudriere/jails/pfSense_factory-v2_4_5_aarch64/usr/src/crypto/openssl/ssl/s3_clnt.c:3266:
    pkg-static: https://repo.netgate.com/pkg/pfSense_factory-v2_4_5_aarch64-pfSense_factory-v2_4_5/All/protobuf-3.9.2,1.txz: Authentication error
    Failed



  • Hello!

    After waiting a bit, I ran the upgrade again, and that time it succeeded. The unit appears to the functioning normally.
    I looked through the /conf/upgrade_log.* files, but wasnt able to determine exactly why it failed the first time and worked the next.

    There were a couple of errors in the install log, but I dont know if they are expected or not :

    Warning: PHP Startup: Unable to load dynamic library 'readline.so' (tried: /usr/local/lib/php/20170718/readline.so ( Shared object "libreadline.so.7" not found, required by "readline.so"), /usr/local/lib/php/20170718/readline.so.so ( Cannot open "/usr/local/lib/php/20170718/readline.so.so")) in Unknown on line 0

    I can provide the logs if they would be helpful.

    John


  • Netgate Administrator

    That's a known issue and is harmless. But thanks for reporting it anyway.

    https://redmine.pfsense.org/issues/9975

    Steve


Log in to reply