HAProxy forwarding to NGINX Seafile



  • Hi guys,

    is there a possibility that the HAProxy completely passes everything that arrives at the domain xyz.domain.de to the internal 192.168.1.30? An NGINX with reverse proxy and Seafile is running on the IP.

    I do not want to create the config from the Seafile server. But I have several 443 applications where I could use the HAProxy.



  • @Lip
    Yes..?
    Are you running into any problem? Haproxy can pass http/ssl/tcp traffic along with various levels of 'processing'.. What did you try, what does the config look like, what didn't work? Perhaps define 'completely passes' with a bit more detail? Normally all requests are passed along to the backend.. if they are valid, and a server is up, and it isn't specifically blocked or cached.. So i'm not sure what/why your asking .?



  • @PiBa

    sorry my description is poor.

    I wanted to know how to set the HAProxy to work. I followed these instructions https://sysadms.de/2018/10/pfsense-haproxy-als-reverse-proxy/ but I am stuck here.

    I don't need the whole http to https redirect. I just want everything to be routed directly to the ngnix. the ngnix also creates and extends the ssl certificate itself.

    can you tell me how best to set that up?



  • @Lip
    How to do it, basically still follow the instructions and don't do what do you don't need.?

    • If you don't want to offload, leave the ssl checkbox on the frontend 'off' and choose for mode 'ssl/https'..
    • As your then not using offloading, also leave the 'Encrypt-SSL' checkbox on the backend server 'off', (but do check the SSL-Checks checkbox..).

    Should be pretty easy.. give it a try, and if it doesn't work show the config as you have made, and tell what the stats page looks like, is the server green and if not what does lastchk column say?.

    I'm not inclined to write a step-by-step guide tailored to a specific user. As that would be more work for me, and less of a learning experience for you.. Really.. if it doesn't work first time you can try again for no additional fee 😉



  • @PiBa said in HAProxy forwarding to NGINX Seafile:

    How to do it, basically still follow the instructions and don't do what do you don't need.?

    If you don't want to offload, leave the ssl checkbox on the frontend 'off' and choose for mode 'ssl/https'..
    As your then not using offloading, also leave the 'Encrypt-SSL' checkbox on the backend server 'off', (but do check the SSL-Checks checkbox..).

    Should be pretty easy.. give it a try, and if it doesn't work show the config as you have made, and tell what the stats page looks like, is the server green and if not what does lastchk column say?.
    I'm not inclined to write a step-by-step guide tailored to a specific user. As that would be more work for me, and less of a learning experience for you.. Really.. if it doesn't work first time you can try again for no additional fee

    Thank you with your help I got it done. Unfortunately I don't understand most of it because it is completely new territory for me. here it is difficult to say what you need and what you don't. the side can be reached from the outside and everything should go :) THANKS again


Log in to reply