multiple networks on 1 interface



  • Hello everyone,

    i am setting up a Pf-sense box for home use, and i am wanting to set it up with a fail over foe when my below average internet fails.

    the fail over device is a Ubiquiti radio link to a friends house and i have that all configured and working.

    home setup is:

    modem is internal in server (Draytek Vigornic 132F), but this exposes its self to the machine as a single network interface. The server is loated in my shed, about 25M from my house, and i have a cat5E cable running from my switch under the house to the shed

    i am hoping and attempting to get the 1 physical NIC on the server to cover both the secondary WAN and the LAN as set out below

    WAN into pfsense =192.168.1.x/24
    secondary WAN into pfsense = 192.168.0.x/24
    pfsense LAN out is 192.168.100.x/24

    under my house the switch i am using is a Dell Powerconnect 6248P this switch supports both L2 and L3 so i can do routing etc with it. my server is plunged into port G0/1 and the Ubiquiti dish is in G0/48

    my intention is that all traffic goes over my connection as per normal, and then if my internet fails, it gets routed over the ubiquiti dish to my friends internet.

    i am hoping this can be done without running another network cable, as that is not very easy to do. and, i can achieve this result as it stands in windows currently by going into the advanced settings of the network adapter and adding the different network into it.

    i hope this all makes sense, if not please hit me up and i will clarify it

    my side is the YELLOW my friends side is the GREEN

    Capture.PNG

    Cheers



  • ok, i think i have an idea, i have watched a few tutorials on it, and as i have a multilayer switch, it is capable of doing it. so i will give it a crack.

    and hope for the best. haha



  • As I think you are discovering, you need to run VLANs on both your pfsense box and your switch(es). Then you can run multiple networks on the same interface/cable.

    Jeff



  • ok, thanks for the help. i have it sorted. and Vlans worked PERFECTLY.

    Cheers

    Jason


Log in to reply