Unusually slow internet



  • I connect my modem to my computer and internet is a functional speed for downloads and streaming.

    However, with the modem via the vm router 2.4.4-RELEASE-p2, internet is too slow.
    I cannot download updates and often the error is:
    Could not resolve host: host.com.

    I have changed the vm router's dns from 1.1.1.1 and 1.0.0.1 to 8.8.8.8 and 8.8.4.4 however no improvement.

    Any suggestions please?

    I'd be happy to download the pfSense update or the hypervisor to download some packages. No need for streaming.



  • @eiger3970 said in Unusually slow internet:

    Any suggestions please?
    1.1.1.1 and 1.0.0.1 to 8.8.8.8 and 8.8.4.4

    Handing over for free (I won't use the word "selling" any more) your private DNS info to those companies give you a minimal gain ...
    When things do not work as advertised, remove or undo your own settings, like these third party DNS settings.
    Default DNS just works.

    Same thing for other error prone things like using a VM : correct it properly or don't use it. Some VM guidelines are present in the manual.

    Sorry, can't say more, as there are no other indications in your message.



  • Thanks for the reminder, I reverted the DNS back to the default 1.1.1.1 and 1.0.0.1.
    The VM is all default settings.
    Here are some ping results:

    [2.4.4-RELEASE][admin@pfSense.localdomain]/root: ping 1.1.1.1
    PING 1.1.1.1 (1.1.1.1): 56 data bytes
    64 bytes from 1.1.1.1: icmp_seq=22 ttl=53 time=8763.690 ms
    64 bytes from 1.1.1.1: icmp_seq=23 ttl=53 time=7825.096 ms
    64 bytes from 1.1.1.1: icmp_seq=24 ttl=53 time=6909.056 ms
    64 bytes from 1.1.1.1: icmp_seq=25 ttl=53 time=5904.342 ms
    64 bytes from 1.1.1.1: icmp_seq=26 ttl=53 time=4902.535 ms
    64 bytes from 1.1.1.1: icmp_seq=27 ttl=53 time=3903.341 ms
    64 bytes from 1.1.1.1: icmp_seq=28 ttl=53 time=3198.614 ms
    64 bytes from 1.1.1.1: icmp_seq=29 ttl=53 time=2520.282 ms
    64 bytes from 1.1.1.1: icmp_seq=30 ttl=53 time=4113.055 ms
    64 bytes from 1.1.1.1: icmp_seq=31 ttl=53 time=3536.268 ms
    64 bytes from 1.1.1.1: icmp_seq=32 ttl=53 time=3094.721 ms
    64 bytes from 1.1.1.1: icmp_seq=33 ttl=53 time=2662.092 ms
    64 bytes from 1.1.1.1: icmp_seq=34 ttl=53 time=1638.059 ms
    64 bytes from 1.1.1.1: icmp_seq=35 ttl=53 time=1357.198 ms
    64 bytes from 1.1.1.1: icmp_seq=36 ttl=53 time=348.077 ms
    64 bytes from 1.1.1.1: icmp_seq=37 ttl=53 time=25635.582 ms
    64 bytes from 1.1.1.1: icmp_seq=38 ttl=53 time=24698.997 ms
    64 bytes from 1.1.1.1: icmp_seq=39 ttl=53 time=23698.353 ms
    64 bytes from 1.1.1.1: icmp_seq=40 ttl=53 time=22752.091 ms
    64 bytes from 1.1.1.1: icmp_seq=41 ttl=53 time=22594.795 ms
    64 bytes from 1.1.1.1: icmp_seq=42 ttl=53 time=22609.487 ms
    64 bytes from 1.1.1.1: icmp_seq=43 ttl=53 time=22465.628 ms
    64 bytes from 1.1.1.1: icmp_seq=44 ttl=53 time=22361.452 ms
    64 bytes from 1.1.1.1: icmp_seq=45 ttl=53 time=21557.271 ms
    64 bytes from 1.1.1.1: icmp_seq=46 ttl=53 time=20954.664 ms
    64 bytes from 1.1.1.1: icmp_seq=47 ttl=53 time=20377.902 ms
    64 bytes from 1.1.1.1: icmp_seq=48 ttl=53 time=20014.878 ms
    64 bytes from 1.1.1.1: icmp_seq=49 ttl=53 time=19974.405 ms
    64 bytes from 1.1.1.1: icmp_seq=50 ttl=53 time=25476.891 ms
    64 bytes from 1.1.1.1: icmp_seq=51 ttl=53 time=24636.228 ms
    64 bytes from 1.1.1.1: icmp_seq=52 ttl=53 time=38036.633 ms
    

    Routing tables:

    [2.4.4-RELEASE][admin@pfSense.localdomain]/root: netstat -r
    
    
    Routing tables
    
    Internet:
    Destination        Gateway            Flags     Netif Expire
    default            172.20.10.1        UGS         ue0
    1.0.0.1            172.20.10.1        UGHS        ue0
    8.8.4.4            172.20.10.1        UGHS        ue0
    localhost          link#4             UH          lo0
    172.20.10.0/28     link#7             U           ue0
    172.20.10.1        5e:f9:38:ee:18:4f  UHS         ue0
    172.20.10.2        link#7             UHS         lo0
    192.168.1.0/24     link#2             U        vtnet1
    pfSense            link#2             UHS         lo0
    
    Internet6:
    Destination        Gateway            Flags     Netif Expire
    localhost          link#4             UH          lo0
    fe80::%vtnet0/64   link#1             U        vtnet0
    fe80::4063:7cff:fe link#1             UHS         lo0
    fe80::%vtnet1/64   link#2             U        vtnet1
    fe80::a42d:d5ff:fe link#2             UHS         lo0
    fe80::%lo0/64      link#4             U           lo0
    fe80::1%lo0        link#4             UHS         lo0
    fe80::%ue0/64      link#7             U           ue0
    fe80::5cf9:38ff:fe link#7             UHS         lo0
    


  • @eiger3970 said in Unusually slow internet:

    from 1.1.1.1: icmp_seq=38 ttl=53 time=24698.997 ms

    then I would not use 1.1.1.1. .....

    Btw : "24698.997 ms" doesn't say anything.
    Could be very bad hardware simulation (VM). Or something upstream ?
    I presume, when you remove the VM out of the equation, the problem is gone ?
    So, again, can't say no more as : learn how to set up you VM correctly and you're done.



  • Thanks.
    This pfSense VM article is what I followed.

    Bit confused with the interfaces, so that may be an issue.


Log in to reply