System/Advanced/Notifications/E-Mail - SMTP Notification E-Mail auth password not updating



  • Hi All,
    I cant get this password to update from whatever password is currently configured.

    If i goto this section and click the "Test SMTP Settings" button i get a message which says

    Could not send the message to <MY EMAIL> -- Error: PLAIN authentication failure [SMTP: Invalid response code received from server (code: 535, response: 5.7.8 Username and Password not accepted. Learn more at 5.7.8 https://support.google.com/mail/?p=BadCredentials 9sm3238113wmo.38 - gsmtp)]
    

    So i generated a NEW app password (this is a gsuite domain gmail account) and put it in the Notification E-Mail auth password section & confirm section.

    I then select "Test SMTP Settings" again and the email is successfully sent so i then go down to the "Save" button at the bottom of the page and click it.

    However, if i then click on say the System Turnables tab and then come back to the Notification tab and select "Test SMTP Settings" again i get the same error message as above. Trying the new password again works still and again saving doesn't actually save it.

    Any ideas here? This is on 2.4.4-RELEASE-p3.



  • This sounds odd. Try entering the new password, then click on the save button at the bottom before hitting the Test SMTP settings button.



  • Weird - that actually worked....

    Is this a bug that I've accidentally hit?



  • 28bb9188-f373-4904-9b18-53d7d454c816-image.png

    It's not a bug. That's the way it's designed to work. I thought it was a little odd when I was first going through it too. I think they can maybe make this statement a little more clear and highlight it in red. In fact maybe that should be another button that saves and then tests the settings in one step.



  • Yeah,
    Admittedly i missed that statement but it is still wrong as it does actually use the NEW password you put in when you click "Test SMTP Settings"

    The problem is, clicking "Test SMTP Settings" seems to revert the password to the old one (as that's the saved one) when the screen refreshes and advises you of the test result.

    Then as you are completely unaware and have (probably) had a valid test you click "Save" finally, but it then just saves the old password.

    So it still seems like its not working as intended even taking into account the statement.



  • I agree, I think that could be improved. It sounds like that behavior may have changed based on your experience. When I first started using pfSense a couple years ago, the test email would not even work until you first hit save. So yeah I can see why it is even more deceiving now. The test email works, so you figure hit save and I'm done.


  • Netgate Administrator

    This could easily be something in your browser filling the credential fields when you switch back to page. I've hit similar things before though not on that page.

    Steve


Log in to reply