Help setting up Pfsense in Virtual Box, I am getting no internet connection to my internal network.



  • Hey everyone thanks for stopping by. I have been trying to set Pfsense up in a VM for several hours now.

    I am bridging the connection to my NIC and creating an internal network. The problem is that the internal network is not able to access the internet.

    I am able to access the Web Config, but not the internet as previously stated. The part I am super confused about is my WAN IP address. Does that IP address need to be on the same subnet as my NIC on my host machine that I am using?

    These are not the exact IP addresses that are being used but same format:
    My current WAN IP address is 192.168.133.2/24 gateway is set to 192.168.133.1/24.
    The IP of the NIC is 192.168.133.133, using default gateway 192.168.133.1.

    I honest have no clue what I am doing incorrectly if anyone can help me out that would be awesome. I am also new to networking (just doing it for at home labs). If you need any more information be sure to ask.

    If you guys use discord feel free to add me Hutch#7588.



  • @RedneckHutch Be sure to uncheck this box to allow private address...Interface > WAN scroll to the bottom of the page, then save...you may need to reboot pfSense.

    Screen Shot 2020-03-17 at 8.16.03 PM.png


  • Netgate Administrator

    If you are bridging the NIC in VBox then that is correct the pfSense WAN should be in the same subnet as the host.

    Can you ping out to external sites from pfSense? From the console for example?

    What are you using for the LAN subnet? It must be different to the WAN and host.

    If you can access the pfSense webgui from some other VM on the LAN and pfSense itself can connect out then you probably don't have any outbound NAT happening. The WAN may not have a gateway actually on the interface for example.

    Steve


  • Netgate Administrator

    @NollipfSense

    This is a common misunderstanding. The block private networks rule only prevents incoming connections to the WAN. You may well want it unchecked in this situation to access the webgui from the WAN side but it will not prevent access to the internet from LAN.

    Steve



  • @stephenw10 said in Help setting up Pfsense in Virtual Box, I am getting no internet connection to my internal network.:

    @NollipfSense

    This is a common misunderstanding. The block private networks rule only prevents incoming connections to the WAN. You may well want it unchecked in this situation to access the webgui from the WAN side but it will not prevent access to the internet from LAN.

    Steve

    Ah, cool...I was trying to remember how I had it two years ago when I first used pfSense and VirtualBox.


Log in to reply