DHCP Server wrong IP CARP



  • Hi, Hopefully one of my last asks for help for HA setup. I've successfully got HA up and running. sync works, failover appears to be working except that on at least my windows machines, both physical and virtual, my DHCP server is showing up as the primary IP, not as the CARP IP.
    b765462a-0e74-4086-9288-8c4546a3fca6-image.png

    LAN DHCP Server is set like this and gateway seems to be working:
    edf194ca-3ccf-4a8b-8eb6-1fa56a7c4e81-image.png

    Is there anywhere else I need to set this so DHCP works properly if I lose my primary?

    Thank you!
    Tiwing



  • This is correct. The DHCP service runs on the interface address of the firewall, not the CARP address. You need to fill in the failover peer ip on each node. Check the DHCP status to see if they are in sync. Sometimes you need to stop and restart the service, then wait a few minutes for them to get in sync.


  • Rebel Alliance Developer Netgate

    The two HA nodes act in a coordinated manner for failover when you properly set them up in the DHCP settings. On the primary, add the secondary interface address in each active DHCP server tab.

    They will both hand out addresses and share lease information. If either one goes down, clients will still obtain an address.

    That is covered in the docs for HA



  • @jimp said in DHCP Server wrong IP CARP:
    On the primary, add the secondary interface address in each active DHCP server tab.

    Yup, did that! Thanks both of you - I didn't realize it was supposed to be that way, and although I've read the HA docs a number of times I guess I missed the part where DHCP server address would show as the actual IP of the box, not the VIP.

    Thank you!
    Cheers
    Tiwing


Log in to reply