I think I am in over my head! Multi-WAN help…Please!



  • Okay so obviously I am new to PFSENSE and am having a hard time. I have 3 WAN connections coming in (all roadrunner cable) and one LAN coming out. I have tried reading the multi-wan/load balancing and cannot translate it into something usable for a simple mind like mine! I am getting the internet through wan1 and can surf and all that good stuff but I really do not even know where to start to get the other WANs setup; let alone set up load balancing. Can anyone help a noob PFSENSE user? Thanks a lot!



  • You are not giving a lot to go on.

    If you have read http://doc.pfsense.org/index.php/Multi_WAN_/_Load_Balancing#Setting_up_load_balancing_and_failover

    Are you able to say at what stage you get stuck? for example have you added you second WAN interface normally referred to as OPT1 with the interfaces you have described?

    This could take some time but I am prepared to assist.

    Cheers

    Paul



  • THanks for the reply and sorry about the vague problem.
    I have added the wans successfully; I guess the problem I am having is that on all my modems (wan, opt1, opt2) are showing up with the same subnet and the same gateway when I check them in interface status window. I have them setup with DHCP if that helps at all. When I make a the pool and  monitor and add the different WANs  I get the same gateway. Then I test them and no go with the load balancing. I hope that helps and I am really appreciative for any help.
    THanks!



  • If all your WAN connections need to use the same gateway I don't think there's any way to do this with just pfSense. You might need a NAT box for each modem, or several different ISPs (probably a good idea anyway).



  • would it be possible to knock up some drawing that shows your network and what is connected to each network interface?

    [EDIT]
    Thinking about this some more the most likely cause is that you have set all three (WAN, Opt1, Opt2) interfaces to bridge. check the "Bridge with" parameter is set to none for eac of the interfaces

    Thanks


Locked