pfsense box stoped assigning IP address to LAN [SOLVED]



  • pfsense box stoped assigning IP address to LAN. Seems like DHCP bug.

    Double check everything, DHCP is on with range 192.168.3.100-120 . Simple LAN /24 network.
    Interface is on static 192.168.3.1. Restart dhcp service, restart the box. tried everything.
    version 2.4.4 P3.

    If i set my network card on pc to take the IP 192.168.3.105 is working !!! Web Gui is also accessible.

    What might be the problem ?? Any help appreciated.



  • Status > System Logs > DHCP stays empty ?

    Diagnostics > Packet Capture (enter DHCP specific settings) : does pfSense actually receive the DHCP requests ? Because : no request => no proposal.

    The top 10 DHCP issue list is :
    1: the admin
    2 : the admin
    3 : the admin (client device was set with static IP / fckd up local firewall rules / etc )
    4 : sun flaire
    5 : broken cable
    6 : broken NIC
    7 : switch
    8 : baldly managed switch
    9 : Did I mention : the admin ?
    10 : Recheck issue 1.
    .....
    44 : pfSense DHCP server.



  • ok i get it... i know most probably i have done something wrong with rules.

    but even i open up all rules on LAN, the issue not resolved.

    I have check everything. cables, switch, hardware, NIC all ok.

    pfSense is not receiving requests on system log.



  • @Bambos said in pfsense box stoped assigning IP address to LAN:

    but even i open up all rules on LAN

    That's not 'the final solution' that makes everything ok again.
    A couple of days ago, someone was posting :

    I had to undo the manual edits of (V)LAN's settings in the config.xml to make everything work again ...
    

    Like : I fckd up the Registry (and won't tell this one the forum) and now Windows goes screen blue ...

    As said above : Packet Capture will show you what shows up on the physical NIC. If nothing shows up^, then you have proof then nothing comes in. Which explains what you see.



  • @Gertjan I think I figured out the problem... please tell me what you think.

    having HA setup, after a switch on LAN disconnected, the backup unit took over and reconfigured the master with some of its settings. some of them was disable DHCP on LAN.

    Obviously i had it enabled on master. Since the nodes was syncing ok, what it might be wrong with this DHCP setting not going to backup at first ?

    Thank you for your reply.


  • LAYER 8 Global Moderator

    @Bambos said in pfsense box stoped assigning IP address to LAN:

    having HA setup, after a switch on LAN disconnected,

    ZERO mention of this in your first post.. <rolleyes>



  • @johnpoz i didn't figured out the RJ45 was cracked.

    After all , i don't understand why now, setting static ip to visit the web gui, enabled DHCP for the LAN but still not work. Is this can be fixed ?


  • LAYER 8 Global Moderator

    Not talking about what you figured out - I am talking a huge difference in a setup when your HA vs when its a single box, etc..

    Did you validate pfsense is seeing the dhcp discover? Troubleshooting dhcp is 30 seconds worth of troubleshooting here... The dhcp service is running or its not running, it sees the discover or it doesn't does it send a offer...

    @Gertjan list is pretty spot on to be honest ;) hehehe


Log in to reply