Home Router Assistance



  • Hi,
    I have a Billion BiPAC 8800NL router connected to my broadband, the LAN side is 192.168.0.0 network.

    I am setting up various services which I use the "Virtual Servers" under the Billion router and I am essentially port forwarding these services (OpenVPN etc) to my pfSense router (WAN also on the 192.168.0.0 network), this works absolutely fine for OpenVPN.

    I also tried adding a IPSEC tunnel, which worked fine between the pfSense router and my phone on WiFi (192.168.0.0 network), the issue is when trying to connect between the pfSense router and an external IP.

    I am suspecting the issue lies within the Billion translating my external IP into an internal NAT IP of the router and the IPSEC on pfSense seeing a difference between my external IP that the request came in and the internal NATed IP of the Billion's LAN address.

    So, going from 192.168.0.5 (phone) - 192.168.0.240 (pfSense router) the connection works fine, changing the phone to use my external broadband IP it doesn't work (on WiFi or phone network), I can see the packets coming in and a connection request within pfSense but it doesn't actually connect.

    Is this just a limitation of my old Billion router NATing instead of actually routing? I tried setting the DMZ to 192.168.0.240, but that made no difference.

    Does IPSEC on pfSense work behind another Router?
    My setup for visual representation is:
    [ADSL] -> [WAN Port (82.23.x.x)][Billion Router][LAN Port (192.168.0.1)] -> [WAN Port(192.168.0.240)][pfSense]

    OpenVPN works fine, but I am just trying to understand why IPSEC doesn't, are my suspicions correct, can I configure anything else to try and get it to work?

    Any help appreciated.

    TIA!


Log in to reply