VLAN's and ssh timeouts, is this asymmetric routing?


  • Hello,

    I have a couple of servers that are running dockers etc, however my main issue is ssh timeouts accessing the host server.

    SSH time out when connecting from 10.1.21.100 and accessing Server2 on 10.1.20.10.

    Is this asymmetrical routing I'm running into? Would doing some extra routing fix the issue or am I missing something here.

    I've tried the following on Server2 to resolve however I had some issues adding default route, need to spend more time on that.

    echo "1 rt21" >> /etc/iproute2/rt_tables
    ip route add 10.1.21.0/24 dev br0.21 src 10.1.21.10 table rt21
    ip route add default via 10.1.21.2 dev br0.21 table rt21
    ip rule add from 10.1.21.10/32 table rt21
    ip rule add to 10.1.21.10/32 table rt21

    • and the same type of routes for vlan20's interface.

    routing3.png
    Thanks,


  • Hello!
    Do you have ip address assigned on the vlans in the switch? I have a similar setup and had a similar problem, ssh timed out after 30 sec. I had missed to remove an ip address on the client vlan in the core switch. After removing that it worked fine.