Upgrade to 2.4.5, locks up twice in 24 hrs


  • I upgraded my home router to 2.4.5 night before last around 11pm, seemed to go fine. I run pfblocker-devel and suricata. Worked from home all day yesterday, no issues. Last night just before 8pm, started watching Tiger King on Netflix (ick, why?), my pfsense box running on Qotom i5 whitebox locked up... hooked up a monitor and keyboard and console was unresponsive. I reset the box, and it came back to life. An hour later, locks up again non-responsive.

    I will restore back to 2.4.4-p3 this morning, and report back. Just wanted to make a report.

  • Rebel Alliance Developer Netgate

    @fnarq said in Upgrade to 2.4.5, locks up twice in 24 hrs:

    started watching Tiger King on Netflix (ick, why?), my pfsense box running on Qotom i5 whitebox locked up...

    Carole Baskin must have broken your router to make sure you don't watch the rest of it. /s

    Kidding aside, typically if the console is completely unresponsive and there was no output on it, that tends to be hardware-related. There is a chance it's from the OS (potentially a driver/hardware interaction of some kind), but that is less likely.


  • So, just to close the loop on this.. see also more woe: reddit post https://old.reddit.com/r/PFSENSE/comments/g0hfon/post_245_upgrade_reconfig_from_scratch/

    This box was just buggy as hell since the 2.4.5 upgrade... not sure what I did wrong. The box would get non-responsive from GUI or ping, I could no longer SSH into the box, I hooked up a monitor and keyboard, and I would find the keyboard non-responsive... I also noticed the resolution on the monitor was much lower than I remembered... was seeing ring_reinit errors on the console and in the logs (related to drivers w/ suricata?)... kinda mostly passed traffic most of the time, but it got sporadically slow at times... I had reinstalled one time but restored the config... kept on suffering... I found the KB unresponsive today... I finally bit the bullet, reinstalled, wiped the box and reconfigured from scratch by hand on 2.4.5.

    Resolution on the monitor is back to normal. I can SSH back into the box again. Yay.


  • @fnarq

    Check if you run block bogons on the interfaces when filter reloads. uncheck them.

    It destroys the box completely....