Dual wan fallover works but fallback doesnt


  • Have a dual wan setup with a primary cable internet with a slow dsl backup.

    When the cable goes down it falls-over as it should to the dsl but when the cable is restored it fails to fall back.

    Cable is tier 1 and monitored with 1.1.1.1.
    Dsl is monitored with 8.8.8.8

    I have the state tables being flushed when the gateway goes down which does help in the short term but any long cable downtime makes this useless.
    Any thoughts..ideas or fixes?
    Untitled.jpg


  • What exactly do you mean by 'it fails to fall back'?
    Does the WAN gateway not show active in the gateway group status?
    If you close your browser, then re-open it and check your public IP, does the browser show the DSL IP?


  • By fallback i mean it doesn't return to using the cable internet as it should when the cable is restored.
    Cable is set to tier 1 and dsl is set to tier 2.

    Once cable is restored it should fallback to using it but it doesn't.

    It remains on the dsl regardless of the state of the cable.

    This is after 10 min the top is the cable and the bottom the dsl.
    Both are working and pfsense should have returned to using the cable which is tier 1 but it doesn't.

    ffdgfdgfdgfdf.jpg


  • You didn't answer the question.
    If you have a persistent connection, like an ongoing download or stream, it will continue to use the backup connection even after the primary has been restored. If you can open a new browser and google 'what's my public ip' and get the cable IP, then everything is working correctly.


  • Our cable 340/15 and our dsl 6/.75 so even without checking the ip in the browser its clearly noticeable.

    We have of course checked the ip which always shows the dsl.

    It doesn't matter if its being used or ideal it remains on the dsl regardless.

    From what i can see in the forums this isn't a isolated problem either.


  • We are also fully aware that pfsense is stateful so its not going to jump to the faster connection once its restored if something in progress but it should on ideal which its not.


  • Going to check System->Advanced->Networking named Reset all states and see if this forces the state tables to update correctly.


  • Check under diagnostics, routes to make your the routes for the monitor addresses are correct.
    Any non-default settings on the gateway group? Have you restarted dpinger?


  • Everything as it should be.

    If i were to unplug the cable and wait a couple minutes and plug it back in it switches back as it should.

    But if a period of time passes the state tables don't update as they should and pfsense assumes the cable still down.

    System->Advanced->Networking named Reset all state may help this as it should reset the state tables when a wan ip address changes clearing out the ones showing cable as down.

    Or at least that's the hope for all i know its caught codvid-19 off me lol.


  • @Magnus33 said in Dual wan fallover works but fallback doesnt:

    System->Advanced->Networking named Reset all state may help this as it should reset the state tables when a wan ip address changes clearing out the ones showing cable as down.

    I think this setting only applies to the IP address changing on an Interface (e.g. new dhcp ip), and has nothing to do with multi-wan.


  • @dotdash said in Dual wan fallover works but fallback doesnt:

    @Magnus33 said in Dual wan fallover works but fallback doesnt:

    System->Advanced->Networking named Reset all state may help this as it should reset the state tables when a wan ip address changes clearing out the ones showing cable as down.

    I think this setting only applies to the IP address changing on an Interface (e.g. new dhcp ip), and has nothing to do with multi-wan.

    Yeah no one seems to quite know for sure if it does or doesn't.

    Same with State Killing on Gateway Failure which should clear the states on a failure but does it do so once or repeatably tell there not a failure is anyone's guess.


  • I been having this Issue for a long time as well, It will not fail back to the primary circuit, i have to go to the secondary circuit and mark getaway as down and force to fail over.