• On my SG-1100, I tried upgrading (from the UI) when I saw the "Version 2.4.5 is available." message. I clicked "Confirm" and after a while, it failed with this error message:

    [43/72] Fetching freetype2-2.10.1.txz: .......... done
    [44/72] Fetching filterdns-2.0_3.txz: .. done
    7538588:error:14099044:SSL routines:ssl3_send_client_verify:internal error:/usr/local/poudriere/jails/pfSense_factory-v2_4_5_aarch64/usr/src/crypto/openssl/ssl/s3_clnt.c:3266:
    7538588:error:14099044:SSL routines:ssl3_send_client_verify:internal error:/usr/local/poudriere/jails/pfSense_factory-v2_4_5_aarch64/usr/src/crypto/openssl/ssl/s3_clnt.c:3266:
    pkg-static: https://repo.netgate.com/pkg/pfSense_factory-v2_4_5_aarch64-pfSense_factory-v2_4_5/All/expat-2.2.8.txz: Authentication error
    Failed
    

    Any Idea why?


  • @viper25 said in Upgrade to 2.4.5 Fails:

    [43/72] Fetching freetype2-2.10.1.txz: .......... done
    [44/72] Fetching filterdns-2.0_3.txz: .. done

    Most probably because the some 100 K pfsense admins are all updating there devices, so the update servers are having a hard time.
    Netgate has probably a pretty solid "repo.netgate.com" server farm, but they could have right now some issues keeping up the pace.

    Just try again later on. 2.4.5 is good, and should be installed. But it's not an urgent "install me now" release. Do not upgrade any packages right now, upgrade to 2.4.5 first (or pay the price ;) ).
    I also advice you to do a clean reboot when possible, so the system has a chance to clean things up if needed.


  • Thank you. Maybe it's a load issue. I did update my packages though. Nothing seems to have broken though. I'll try after a few days and report here!

  • Netgate Administrator

    Mmm, the exact cause of that error is unknow (to me at least!) at this time. But when I have seen it I have simply re-run the operation and it succeeded.

    Steve


  • @stephenw10 said in Upgrade to 2.4.5 Fails:

    Mmm, the exact cause of that error is unknow (to me at least!) at this time. But when I have seen it I have simply re-run the operation and it succeeded.

    Steve

    I re-ran it multiple times over a couple of days but couldn't get it to work. Strangely around this time, my internet kept dropping around this time every hour or less. I don't know if it's related. Anyway I'll re-flashing my device (SG-1100) with the latest pfSense version since I have these unexplained internet disconnects

  • Netgate Administrator

    It certainly could be related. If you were seeing connection issues during the package download it would fail.

    Steve